0810 Ubuntu Packages

From LinuxMCE
Revision as of 22:25, 4 November 2008 by Jimbodude (Talk | contribs) (updated some package information)

Jump to: navigation, search

The following packages are currently in the ubuntu dir, and are being patched in 0710. We need to find out, which of these packages are no longer in need for patching due to the patches being incorporated into the upstream packages.

This list is a verbatim copy of the directory. If anyone has any input, please modify accordingly.

asterisk

alsa-driver-1.0.16

alsa version 1.0.16 comes from Ubuntu 8.04. There are a few source differences between what is in SVN and what is in the Ubuntu package. I have not been able to find a patch that would create these changes. ALSA version 1.0.17 is in Ubuntu 8.10, so I won't waste much time looking. -- Jimbodude 23:25, 4 November 2008 (CET)

djmount-0.71

Does not exist in Intrepid default repositories (do not exist in contents.gz file). What is is? It´s a userspace utility that connects to upnp media servers and present their content as ordinary linux filesystems.

We need this one if UpdateMedia should be able to recognize media from upnp media servers.

ffmpeg

ffmpeg

ffmpeg-svn12476

fuppes-0+svn578

Seems it is not included in Intrepid anymore (Does not exist in contents.gz file). Need to check more, but Niz23 cannot find it in Intrepid pool directories. Zaerc suspects it was never included in Ubuntu to begin with [1].

Nothing special is done to this source as far as Niz23 knows since no integration exist against lmce yet.

Source appears to have come from here. No source or directory structure changes between that source and LMCE's SVN. Differences do exist between that version and Fuppes SVN - none are source related, just some make files and directory structure. Fuppes SVN:578 is dated Wed Dec 19 13:27:54 2007 UTC - latest activity is SVN:627 dated Tue Oct 28 11:34:09 2008 UTC. SVN:578 is the "current release" according to the fuppes website. -- Jimbodude 23:25, 4 November 2008 (CET)

libdvdcss-1.2.9

This package is nowadays included in the Medibuntu Repository as libdvdcss2. So probably obsolete but some testing is needed.

libsdl

No longer needed as of 0804.

libsdl1.2-1.2.7+1.2.8cvs20041007

libsdl1.2-1.2.12

Used in 0710. According to Zaerc, all changes are in the upstream package

linphone-1.3.5

Was used in 0710, but left out of 0804. Needs further examination, probably obsolete.

linux-image-dummy

lirc

Intrepid uses version 0.8.3-0ubuntu2 at the moment, this newer version will probably have to be patched just like lirc-0.8.3~pre1+lmce as well.

lirc-0.8.2+lmce

Used in 0710.

lirc-0.8.3~pre1+lmce

Used in 0804, contains one patch originally made by Radu.

lirc-pluto-0.1

lshwd-2.0-rc4

mplayer

mplayer

mplayer-svn26234

mtx

mtx-1.3.10

mtx-1.3.11

mythtv-0.20.2+fixes14472

parted-1.8.8

This version of parted is now standard in Ubuntu 8.10. Ubuntu packages shows no source differences from what is in SVN. -- Jimbodude 22:24, 4 November 2008 (CET)

spcp8x5

Seems to be included in 0810's kernel by default, so likely obsolete.

ushare-0.9.6

No real reason to use this one. It´s not installed in lmce0710 so we won´t need it in 0810 either.

It can be replaced with other upnp/dlna servers like fuppes, Mediatomb etc.

via-udeb

xine-lib

Patched versions are no longer needed as of 0804.

xine-lib-1.1.3

xine-lib-1.1.7

xine-lib-1.1.10.1

Was used in 0710. According to Zaerc, all changes are in the upstream package