Difference between revisions of "Android Orbiter"

From LinuxMCE
Jump to: navigation, search
(Configuration)
(Install Qorbiter)
 
(32 intermediate revisions by 7 users not shown)
Line 1: Line 1:
=LinuxMCE Orbiter for Android=
+
=LinuxMCE QOrbiter for Android=
This wiki page serves 2 purposes: To serve as an intermediate install guide for the Android LinuxMCE Orbiter, and to serve as a point of reference for future developers.
+
This wiki page serves 2 purposes: To serve as an intermediate install guide for the Android LinuxMCE QOrbiter, and to serve as a point of reference for future developers.
  
 
==History==
 
==History==
The Android orbiter is the result of a very tricky process. We utilize the LinuxMCE libraries, qt libraries, and wrap them inside java for execution on the Android device. Besides using vanilla Qt Creator, we also utilize Neccesitas, a cross platform compiler that takes the Native c++ and wraps it for executing inside the Android JNI  
+
===Original Implementation using Qt4===
 +
This version is being retired and you should use the Qt5 version
 +
The Android qorbiter is the result of a very tricky process. We utilize the LinuxMCE libraries, qt libraries, and wrap them inside java for execution on the Android device. Besides using vanilla Qt Creator, we also utilize Neccesitas, a cross platform compiler that takes the Native c++ and wraps it for executing inside the Android JNI.
 +
 
 +
===Latest Implementation using Qt5===
 +
As a result of Digia aquiring Qt, they have made an effort to extend Qt to both iOS and Android. The result of this
 +
effort so far is Qt5.2.0 for Android. This release brings the advances gained in Qt5 to the android platform, as well
 +
as some other features, not the least of which is no longer needing ministro to download qt libraries. Release will be available soon,
 +
there is just much porting to QtQuick2 that needs to be done.
  
 
=Installation=
 
=Installation=
Please note, you will need 50mb of storage space on the devices internal storage. NOT the sd card. You will also need to install via wifi!!
+
Please note, you will need 30mb of storage space on the devices internal storage. NOT the sd card. You will also need to install via wifi!!
*Download the testing apk: http://lasmarthomes.com/QOrbiter-release.apk
+
 
*Install the .apk
+
*When it is finished, it will ask you for to download Ministro II. Do this and let it finish.
+
QOrbiter is now installed!
+
  
 
==Configuration==
 
==Configuration==
 
You will need to prepare for the addition of the device to your system before it can be used by following these steps.
 
You will need to prepare for the addition of the device to your system before it can be used by following these steps.
*Create a new QOrbiter device as a child of the core. MAKE SURE to set the default user and location. '''Make a note of the device number'''
+
*Navigate to the 'Orbiters' page in the LinuxMCE Admin website. Create a new QOrbiter device from the dropdown box at the bottom. Make sure you fill in all the information there like:
 +
**User
 +
**Room
 +
**Size - This is a remnant of the old orbiter, choose the smallest one, so that any regen it does is fast.  
 +
**'''Make a note of the device number'''
 +
*When done, choose update.
 +
*When the core is ready, it will ask you to do a quick reload. MAKE SURE to set the default user and location.
 
*Quick Reload the router when asked.  
 
*Quick Reload the router when asked.  
*Generate the orbiter config by visiting this page http://<you-core-address>/lmce-admin/qOrbiterGenerator.php?d=<the-device-number>
+
*When you start the android QOrbiter, it should pop up a list of orbiters. Select the appropriate one, and it should finish setup.
  
Now you will need to decide on a skin. Eventually, this will be a cleaner process. For the moment, it isnt :)
+
Now you will need to Install the skins. Eventually, this will be a cleaner process. For the moment, it isnt :)
All skins live on the core and will be accessible from http://<your-route-ip>/lmce-admin/skins The following instructions are for the core machine.
+
All skins live on the core and will be accessible from http://<your-route-ip>/lmce-admin/skins The following instructions are for the '''core''' machine. you may need to run these commands with 'sudo'. These commands will download a script written for your LinuxMCE core. It will setup and update the critical files needed while QOrbiter is in this beta state. Thank you for your patience.
  
All skins need a skins directory:
 
mkdir -p /var/www/lmce-admin/skins
 
===Phones===
 
You will need to checkout the skin using subversion.
 
svn co http://svn.linuxmce.org/svn/branches/LinuxMCE-1004/src/qOrbiter/qOrbiter_src/qml /var/www/lmce-admin/skins
 
This will download the skins to the proper location.
 
  
===Tablets===
+
  wget http://langstonball.com/qorbiter/setupQorbiter.sh -O /tmp/setupQorbiter.sh
You will need to download the skin from its current home, and unzip it into the proper directory.
+
sudo chmod u+x /tmp/setupQorbiter.sh
  wget http://www.lasmarthomes.com/tabletskin.zip
+
sudo /tmp/./setupQorbiter.sh
unzip -d /var/www/lmce-admin/skins/android/phone/ tabletskin.zip
+
  
Now your tablet skin is installed.
+
 
 +
Now your skins are installed.
 +
 
 +
==Install Qorbiter==
 +
*Nightly builds can be obtained at  http://deb.linuxmce.org/QOrbiterQt5-release.apk
 +
*Install the .apk
 +
QOrbiter is now installed!
  
 
==Running the device==
 
==Running the device==
Line 42: Line 52:
  
 
The configuration file is located on the SDCard under /LinuxMCE
 
The configuration file is located on the SDCard under /LinuxMCE
 +
 +
==Remote Access==
 +
 +
In order to use qOrbiter from outside your internal LMCE network, you need to:
 +
*Open ports 2757 & 3450 on your firewall via webadmin
 +
*Change the host line in LinuxMCE/config.xml on your Android device to your CORE's external IP address.
 +
*Please note this is an unsafe activity. It would be wiser to setup vpn support.
 +
 +
[[Category:Programmer's Guide]][[Category:QML]][[category:QOrbiter]]
 +
 +
=Beta Test=
 +
 +
 +
Don't forget to help put the qOrbiter through its paces! http://forum.linuxmce.org/index.php/topic,13344.0.html

Latest revision as of 17:44, 3 January 2015

LinuxMCE QOrbiter for Android

This wiki page serves 2 purposes: To serve as an intermediate install guide for the Android LinuxMCE QOrbiter, and to serve as a point of reference for future developers.

History

Original Implementation using Qt4

This version is being retired and you should use the Qt5 version

The Android qorbiter is the result of a very tricky process. We utilize the LinuxMCE libraries, qt libraries, and wrap them inside java for execution on the Android device. Besides using vanilla Qt Creator, we also utilize Neccesitas, a cross platform compiler that takes the Native c++ and wraps it for executing inside the Android JNI.

Latest Implementation using Qt5

As a result of Digia aquiring Qt, they have made an effort to extend Qt to both iOS and Android. The result of this effort so far is Qt5.2.0 for Android. This release brings the advances gained in Qt5 to the android platform, as well as some other features, not the least of which is no longer needing ministro to download qt libraries. Release will be available soon, there is just much porting to QtQuick2 that needs to be done.

Installation

Please note, you will need 30mb of storage space on the devices internal storage. NOT the sd card. You will also need to install via wifi!!


Configuration

You will need to prepare for the addition of the device to your system before it can be used by following these steps.

  • Navigate to the 'Orbiters' page in the LinuxMCE Admin website. Create a new QOrbiter device from the dropdown box at the bottom. Make sure you fill in all the information there like:
    • User
    • Room
    • Size - This is a remnant of the old orbiter, choose the smallest one, so that any regen it does is fast.
    • Make a note of the device number
  • When done, choose update.
  • When the core is ready, it will ask you to do a quick reload. MAKE SURE to set the default user and location.
  • Quick Reload the router when asked.
  • When you start the android QOrbiter, it should pop up a list of orbiters. Select the appropriate one, and it should finish setup.

Now you will need to Install the skins. Eventually, this will be a cleaner process. For the moment, it isnt :) All skins live on the core and will be accessible from http://<your-route-ip>/lmce-admin/skins The following instructions are for the core machine. you may need to run these commands with 'sudo'. These commands will download a script written for your LinuxMCE core. It will setup and update the critical files needed while QOrbiter is in this beta state. Thank you for your patience.


wget http://langstonball.com/qorbiter/setupQorbiter.sh -O /tmp/setupQorbiter.sh
sudo chmod u+x /tmp/setupQorbiter.sh
sudo /tmp/./setupQorbiter.sh


Now your skins are installed.

Install Qorbiter

QOrbiter is now installed!

Running the device

  • Assuming the previous steps were completed, you can now connect.
  • The default ip it connects to is 192.168.80.1
  • Enter the device number you previously made note of for the device number
  • If your core address is not standard, it will hang. you can kill the device and edit the config.xml at the location listed below.

The configuration file is located on the SDCard under /LinuxMCE

Remote Access

In order to use qOrbiter from outside your internal LMCE network, you need to:

  • Open ports 2757 & 3450 on your firewall via webadmin
  • Change the host line in LinuxMCE/config.xml on your Android device to your CORE's external IP address.
  • Please note this is an unsafe activity. It would be wiser to setup vpn support.

Beta Test

Don't forget to help put the qOrbiter through its paces! http://forum.linuxmce.org/index.php/topic,13344.0.html