Difference between revisions of "Build Maemo Orbiter"

From LinuxMCE
Jump to: navigation, search
 
Line 16: Line 16:
 
To install Maemo SDK from the scratch just follow by that [http://maemo-sdk.garage.maemo.org/install-debian.html Debian] or [http://maemo-sdk.garage.maemo.org/install-ubuntu.html Ubuntu] instructions.
 
To install Maemo SDK from the scratch just follow by that [http://maemo-sdk.garage.maemo.org/install-debian.html Debian] or [http://maemo-sdk.garage.maemo.org/install-ubuntu.html Ubuntu] instructions.
  
The instructions on [http://tablets-dev.nokia.com/4.1/INSTALL.txt this page] are good too, and don't need any special tinkering. They seem to require a lot less interaction than the previous way.
+
The instructions on [https://web.archive.org/web/20120113135255/http://tablets-dev.nokia.com/4.1/INSTALL.txt this (Wayback) page] are good too, and don't need any special tinkering. They seem to require a lot less interaction than the previous way.
  
 
===Use ready-made VMWare Appliance===
 
===Use ready-made VMWare Appliance===

Latest revision as of 21:42, 27 May 2016

This article is a stub and requires expansion
The instructions on this page aren't usable at this point.

Setup Environment

To build Maemo Orbiter we should have installed Maemo SDK under Scratchbox. There are two ways to to that.

Install environment from the scratch

To install Maemo SDK from the scratch just follow by that Debian or Ubuntu instructions.

The instructions on this (Wayback) page are good too, and don't need any special tinkering. They seem to require a lot less interaction than the previous way.

Use ready-made VMWare Appliance

The latest version of VMWare Appliance can be downloaded here. To run it you need free VMWave player which available for Linux, Windows and Mac OSX.

Required packages

These packages can be installed by apt-get, and are pre-installed with the development option.

  • libsdl-image1.2-dev
  • libsdl1.2-dev
  • libxmu-dev

The following packages aren't in any official repository, and need to be built from source until someone publishes them:

  • libsdl-ttf2.0-dev
  • libsdl-gfx1.2-dev
  • libgle3-dev
  • libsdl-sge-dev
  • libhid-dev
  • libmysqlclient12-dev
  • libhttpfetcher-dev

Build Orbiter

To build Maemo Orbiter:

  • checkout the latest sources (0810):
svn co http://svn.linuxmce.org/svn/branches/LinuxMCE-0810
  • go to Orbiter/Maemo and run make_package.sh