Foxconn nT330i

From LinuxMCE
Revision as of 13:27, 9 January 2011 by Daballiemo (Talk | contribs) (forgot modprobe ;-()

Jump to: navigation, search
Version Status Date Updated Updated By
710 Unknown N/A N/A
810 Working 27th November 2010 daballiemo
1004 Unknown N/A N/A
1204 Unknown N/A N/A
1404 Unknown N/A N/A
Usage Information

Foxconn nT330I

Note: <MD#> has to be replaced by the mediadirector number.

Note: below is based on having only one connection to TV being HDMI

Prepare the core;

The LAN controller Attansic requires module atl1c. Without it I have kernel panic during an attempt to PXE boot. Way to get the nT330i to work is also described in wiki page http://wiki.linuxmce.org/index.php/Unrecognized_NIC, section Modify the media director initial ramdisk.

cd /
mkdir AR81Family
cd AR81Family
wget http://lnx.sensibile.it/files/foxconn/AR81Family-linux-v1.0.1.4.tar.gz
tar -xvf AR81Family-linux-v1.0.1.4.tar.gz

Build the atl1c kernel module

Modify .src/makefile changing "DRIVER_NAME = atl1e" to "DRIVER_NAME = atl1c";

cd src
vim Makefile

Save the file and start building;

cd ..
make
make install
modprobe atl1c

You'll get some error messages but I noticed still atl1c.ko is build. atl1kc is located in ./src

cp /AR81Family/src/atl1c.ko /lib/modules/`uname -r`/kernel/drivers/net/

In the bottom of /etc/initramfs-tools-interactor/modules add "atl1c" without quotations and save

vim /etc/initramfs-tools-interactor/modules

Now rebuild the initial diskless image


/usr/pluto/bin/Diskless_BuildDefaultImage.sh

MD Time

After this you can connect your MD and take it for its first boot.....

When the initial MD has been created the first boot "real" boot will fail (blue ubuntu bar stops moving) due to the fact the MD image has no atl1c module so we have to add that;

cp /lib/modules/`uname -r`/kernel/drivers/net/atl1c.ko /usr/pluto/diskless/<MD#>/lib/modules/`uname -r`/kernel/drivers/net/ 

In the bottom of /usr/pluto/diskless/<MD#>/etc/modules add "atl1c" without quotations and save In the bottom of /usr/pluto/diskless/<MD#>/etc/initramfs-tools/modules add "atl1c" without quotations and save

Now rebuild the image;

cd /usr/pluto/diskless/
chroot <MD#>
depmod
cd /boot
mkinitramfs -o initrd.img-`uname -r` `uname -r`
exit


Note: do not forget that if you recreate this MD you have to do the above ("MD Time") again before it will fully start.


Finishing off

The system will do a couple of reboots and will at the end put you into AVWizard which does not appear (and do not forget; give it some time). You can check if AVWizard is up by logging in to the MD and run "top". AVWizard should be in the list.

Tip 1) if you press "3" in AVWizard (HDMI2) and WAIT!!! -> voila!!

Tip 2) HDMI sound? In alsamixer unmuted input IEC958 by pressing "m" if selected.

Extra

To have wake on lan working change the setting in the bios for "deep sleep" into disabled and change wake up by PCIE to enabled.