Difference between revisions of "How to setup ADSL access?"

From LinuxMCE
Jump to: navigation, search
Line 1: Line 1:
<table width="100%"> <tr><td bgcolor="#FFCFCF">This page was written by Pluto and imported with their permission when LinuxMCE branched off in February, 2007.  In general any information should apply to LinuxMCE.  However, this page should be edited to reflect changes to LinuxMCE and remove old references to Pluto.</td></tr> </table>Setting up ADSL connection is not yet fully supported under Pluto. But there is relatively simple procedure to get it up and running. I'm posting my notes (hopefully didn'y forget anything important)...<br>
+
Setting up ADSL connection is not yet fully supported under LinuxMCE. But there is relatively simple procedure to get it up and running. I'm posting my notes (hopefully didn't forget anything important)...<br>
  
  

Revision as of 13:53, 16 March 2007

Setting up ADSL connection is not yet fully supported under LinuxMCE. But there is relatively simple procedure to get it up and running. I'm posting my notes (hopefully didn't forget anything important)...


  1. setup two network cards as normally
  2. run pppoeconfig (follow instructions on screen)
  3. go into database - this is the SQL query for the database to see the current setting:
select * from Device_DeviceData where FK_Device=1 and FK_DeviceData=32; 

the data will look something like this:

eth1,10.0.0.85,255.255.255.0,10.0.0.1,10.0.0.150|eth0,192.168.80.1,255.255.255.0

you'll have to change the proper ethX in that string (eth1 in my case) with ppp0


4. put /etc/init.d/start_pppoe.sh and link it to /etc/rc2.d/S10start_pppoe


Content of start_pppoe.sh :


#!/bin/bash
export PATH="/usr/pluto/bin:$PATH"
. /usr/pluto/bin/pluto.func
if  -e /usr/pluto/install/.notdone ; then exit 1
fi
Logging "server" "1" "$0" "Running 'start_pppoe.sh'  ( \"/etc/init.d/start_pppoe.sh\" )"
ifconfig eth1 up
pon dsl-provider


I hope that this will soon be easier to setup over web-admin page.