Difference between revisions of "Install Test in VM - Xenial amd64 - 2017-05-17"

From LinuxMCE
Jump to: navigation, search
(Wrote content.)
 
(Installation Status)
Line 12: Line 12:
 
== Installation Status ==
 
== Installation Status ==
  
Install was OK, no errors during package install.
+
Install was OK, no errors during package install. EDIT: (None of the database tables were created)
  
 
== Web admin user creation ==
 
== Web admin user creation ==

Revision as of 23:00, 17 May 2017

System setup

  • VMWare 12
  • Amd64
  • 8GB RAM
  • 40GB system disk
  • NIC 0: Public (VMNet0) bridged to main network Detected as ens33
  • NIC 1: Private (VMNet1) (192.168.80.0/24) set up as private network, detected as ens34
  • USB 3.0 hub
  • OS: Xenial 16.04 Server
  • Installed as: Core

Installation Status

Install was OK, no errors during package install. EDIT: (None of the database tables were created)

Web admin user creation

Failed with HTTP Error 500, due to:

[Wed May 17 15:34:47.833416 2017] [:error] [pid 1948] [client 192.168.1.16:60517] PHP Warning:  mysqli_real_connect(): (HY000/1698): Access denied for user 'root'@'localhost' in /var/www/lmce-admin/include/adodb/drivers/adodb-mysqli.inc.php on line 124
[Wed May 17 15:34:47.833466 2017] [:error] [pid 1948] [client 192.168.1.16:60517] PHP Fatal error:  mysqli error: [1698: Access denied for user 'root'@'localhost'] in CONNECT(localhost, '****', '****', pluto_main)\n in /var/www/lmce-admin/include/adodb/adodb-errorhandler.inc.php on line 79

I previously was able to get around this by issuing a CREATE USER root@localhost; but this no longer works.

Diskless Creation

Diskless_CreateTBZ still hard-creates i386 images. At the very least, amd64 images should be created on amd64 hosts, and ideally, both i386 and amd64 images should be built when Diskless_CreateTBZ.sh is called. Diskless_CreateTBZ seems to create without incident, however since I can't get into the web admin, can't do much more beyond this.

Conclusion

Build seems to be blocked due to database permission issues. (using -uroot as non-root user causes an access denied).

--Tschak909 (talk) 22:52, 17 May 2017 (UTC)