Installer Problems

From LinuxMCE
Revision as of 17:58, 28 March 2007 by Espace (Talk | contribs)

(diff) ←Older revision | view current revision (diff) | Newer revision→ (diff)
Jump to: navigation, search

Installer Problems

1. vim package

If your /var/log/mce-install* log file is ending with:

 The following packages have unmet dependencies.
 pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 1.0) but it is not going to be installed
                  Depends: pluto-confirm-dependencies (< 1.1) but it is not going to be installed
                  Depends: pluto-createdevice (>= 1.0) but it is not going to be installed
                  Depends: pluto-createdevice (< 1.1) but it is not going to be installed
                  Depends: pluto-install-scripts (>= 1.0) but it is not going to be installed
                  Depends: pluto-install-scripts (< 1.1) but it is not going to be installed
                  Depends: pluto-local-database (>= 1.0) but it is not going to be installed
                  Depends: pluto-local-database (< 1.1) but it is not going to be installed
                  Depends: pluto-std-plugins (>= 1.0) but it is not going to be installed
                  Depends: pluto-std-plugins (< 1.1) but it is not going to be installed
                  Depends: pluto-system-database (>= 1.0) but it is not going to be installed
                  Depends: pluto-system-database (< 1.1) but it is not going to be installed
                  Depends: pluto-website-admin (>= 1.0) but it is not going to be installed
                  Depends: pluto-website-admin (< 1.1) but it is not going to be installed
                  Depends: pluto-boot-scripts (>= 1.0) but it is not going to be installed
                  Depends: pluto-boot-scripts (< 1.1) but it is not going to be installed
                  PreDepends: vim but it is not going to be installed
 E: Broken packages

If you will try to install the vim package 'apt-get install vim', you will get the error:

 The following packages have unmet dependencies.
 vim: Depends: vim-common (= 1:7.0-035+1ubuntu5) but 1:7.0-164+1ubuntu6~edgy1 is to be installed

Solution:

 *Remove and install vim again, 'apt-get remove vim' and 'apt-get install vim'
 *Use some package management tools (aptitude, synaptic) to fix the vim package.
 *Remove the 'edgy-backports' line from /etc/apt/sources.list

Once the vim package is updated/installed well, try again to install LinuxMCE.