Difference between revisions of "Installing Flash"

From LinuxMCE
Jump to: navigation, search
m (add category plus update about flash 10)
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
[[Category:Tutorials]]
+
[[Category:software]]
  
 
==Adobe Flash Player==
 
==Adobe Flash Player==
Line 8: Line 8:
 
Will update once new version is out to see if code still applies
 
Will update once new version is out to see if code still applies
 
'''
 
'''
*First in the KDE desktop, open the console
+
*First in the KDE desktop,
 +
 
 +
open the console
 
*Code:  
 
*Code:  
 
  sudo apt-get install nspluginwrapper  (it may ask for your password, which is linuxmce, if you installed from the DVD)
 
  sudo apt-get install nspluginwrapper  (it may ask for your password, which is linuxmce, if you installed from the DVD)
 
*Next type:  
 
*Next type:  
  wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
+
  wget http://download.macromedia.com/pub/flashplayer/installers/current/9/install_flash_player_9.tar.gz
  tar xvfz install_flash_player_9_linux.tar.gz
+
  tar xvfz install_flash_player_9.tar.gz
 
* Next Type:  
 
* Next Type:  
 
  mkdir -pv ~/.mozilla/plugins
 
  mkdir -pv ~/.mozilla/plugins
  cp -iv install_flash_player_9_linux/libflashplayer.so ~/.mozilla/plugins
+
  cp -iv libflashplayer.so ~/.mozilla/plugins
 
  nspluginwrapper -i ~/.mozilla/plugins/libflashplayer.so
 
  nspluginwrapper -i ~/.mozilla/plugins/libflashplayer.so
 
*Close firefox and then reopen and test, it should now play flash.
 
*Close firefox and then reopen and test, it should now play flash.

Latest revision as of 02:20, 20 October 2012


Adobe Flash Player

Adobe Flash Player is the high-performance, lightweight, highly expressive client runtime that delivers powerful and consistent user experiences across major operating systems, browsers, mobile phones, and devices.

Installing On AMD64 Machines

Update: An alpha version of 64-bit Adobe Flash Player 10 for Linux operating systems was released on 11/17/2008. This should make the instructions below obsolete. However, since LinuxMCE runs an older version of Kubuntu these instructions are still valid. Will update once new version is out to see if code still applies

  • First in the KDE desktop,

open the console

  • Code:
sudo apt-get install nspluginwrapper   (it may ask for your password, which is linuxmce, if you installed from the DVD)
  • Next type:
wget http://download.macromedia.com/pub/flashplayer/installers/current/9/install_flash_player_9.tar.gz
tar xvfz install_flash_player_9.tar.gz
  • Next Type:
mkdir -pv ~/.mozilla/plugins
cp -iv libflashplayer.so ~/.mozilla/plugins
nspluginwrapper -i ~/.mozilla/plugins/libflashplayer.so
  • Close firefox and then reopen and test, it should now play flash.