Difference between revisions of "Known Issues"

From LinuxMCE
Jump to: navigation, search
(Known issues with LinuxMCE 0704)
 
(44 intermediate revisions by 15 users not shown)
Line 1: Line 1:
== Known issues with LinuxMCE 0704 ==
+
[[Category: Known Issues]]
 +
{| align="right"
 +
  | __TOC__
 +
  |}
  
''' * This issue may effect everyone using the Quick Install DVD '''  The quick install DVD is basically an image of a pre-installed Kubuntu + LinuxMCE system that is copied to your system, and then some auto configuration is done to account for regional and network differences.  When the system first boots it is not correctly reconfiguring the network, but still has the same IP address as the pre-installed system that was used as a template.  So if the network in your home isn't the same (ie same gateway) you probably won't have internet connectivity on the first boot.  This means you won't see the gallery art from flicker, and on the 'add software' tab you won't see any software to add, because this list is populated over the internet.  The work around is as follows: As shown in the demo video, enter your name when the setup wizard starts, and select 'OK' when it confirms your password for the admin site.  But then, before proceeding, click 'KDE Desktop', and wait for KDE to start.  Click the KDE 'Start' icon in the lower left, choose Internet, Firefox.  Try to go to a web site.  If it works, you have network connection.  Close Firefox and select 'Activate Orbiter' in the launch manager to go back into Orbiter and keep going with the installation.  If you do not have a network connection, then close Firefox and click 'Launch admin web site' in launch manager.  Log in.  The username and password are both the name you just provided in the setup wizard.  Choose Advanced, Networking, Network Settings.  Confirm the settings are correct, click update, and wait about 20 seconds for it to reconfigure the network.  Then bring up Firefox and confirm you have an internet connection.  There is also a 'Swap Interfaces' button in case you have dual NIC's and LinuxMCE has it backwards which is the internal vs. external NIC.  Once you confirm you have an internet connection, click the KDE Start button, choose System, Konsole.  In the console type: sudo /usr/pluto/bin/getxmls
+
== Known issues with LinuxMCE 0810 ==
 +
*[[LinuxMCE-0810_beta|Known issues with 0810 Beta]]
  
This will update the list of available software that is shown in the add software tab.  Then choose the KDE start button and click Logout and Reboot.  When it boots up it will have an internet connection and again try to detect your regional settings.  The setup wizard will start again since you didn't finish it the first time.
+
== Known issues with LinuxMCE 0710 ==
 +
*[[Known_Issues_0710|Known issues with 0710 RC2]]
 +
*[[Known_Issues_0710_RC1|Known issues with 0710 RC1]]
 +
*[[Known_Issues_0710_Beta4|Known issues with 0710 Beta4]]
 +
*[[Known_Issues_0710_Beta3|Known issues with 0710 Beta3]]
  
== Known issues with LinuxMCE 1.0 ==
+
== Known issues with LinuxMCE 0704 ==
  
It is best to install version 1.0 on a separate box, rather than your main Ubuntu system because of the following issues:
+
*[[Known_Issues_0704|Known issues with 0704]]
  
*  The installer is messing up Ubuntu's xorg.conf file by removing the nvidia driver and replacing it with vesa.  This was actually a necessary hack that got forgotten about.  There is a bug in the nVidia drivers (it has been reported) that causes them to crash when two X sessions are running and try to open the same card.  Using the 'nv' driver on one and the 'nvidia' on the other still doesn't work, but using vesa on one and nvidia on the other does.  So the hack changes Ubuntu's xorg.conf from nVidia to Vesa.  If you install a dedicated LinuxMCE box this isn't an issue, but it can be a problem when you are a Ubuntu user and want better performance on your Ubuntu desktop than the vesa driver allows.
+
== Known issues with LinuxMCE 1.1 ==
  
* The installer will revert the Ubuntu sources.list back to the default, removing any non-standard repositories, when it does the upgrade before installing itself.
+
*[[Known_Issues_11Beta|Known issues with LinuxMCE 1.1 Beta]]
  
*  As mentioned in other places, the scripts carried from Pluto were written to be run on a dedicated system and 'take over' completely.  It was a huge task just getting LinuxMCE 1.0 out the door, and the Ubuntu integration is still a work in progress and the scripts are still too invasive.  If this is a dedicated system, or if you're not a Linux user, this is perhaps still a good thing because you'll never need to touch your configuration files: LinuxMCE will setup the dhcp server, samba network shares, network settings, and so on.  But, if you are a Ubuntu user, be warned that it will override some of your settings until we get the Ubuntu integration improved.
+
== Known issues with LinuxMCE 1.0 ==
 
+
Additional issues:
+
 
+
*  Most of the problems reported so far are caused by using UI2, which requires OpenGL, on video cards without good Linux OpenGL support.  The solution is to use UI1 instead.  nVidia 6xxx and higher are preferred and will run UI2 with the 3d effects and alpha blending.
+
 
+
*  A bug in the media browser was identified that is causing it to run very slow and consume a lot of memory.  A 1.01 patch will be out soon.
+
 
+
*  In the haste to release the updated LinuxMCE 1.0 that didn't use the website for downloading the software after the Digg story brought the server down, there was a sloppy error building the package for the Windows binaries.  Most of them are empty.  This means the Windows orbiter that runs on web pads, pda's and ms smart phones, as well as some other windows applets which are also on the download page in your Core's admin web site, are missing.
+
 
+
* Some of the users reported having broken packages during the installation of  LinuxMCE, usually 'pluto-orbiter' package. This could happen from a number of reasons. We have identified a few of them, such as:
+
- the vim package cannot be installed because of a conflict at 'vim-common'. For details on how to fix that, please follow:  [http://wiki.linuxmce.com/index.php/Installer_Problems]
+
- The Ubuntu repositories are sometimes unavailable. You should try reinstalling, or installing the packages by hand
+
 
+
== Known issues with LinuxMCE 1.1 Beta ==
+
 
+
* if you get the following error:
+
 
+
pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-confirm-dependencies (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-createdevice (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-createdevice (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-install-scripts (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-install-scripts (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-local-database (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-local-database (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-std-plugins (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-std-plugins (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-system-database (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-system-database (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-website-admin (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-website-admin (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-boot-scripts (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-boot-scripts (< 2.0.0.45) but it is not going to be installed
+
                  PreDepends: samba but it is not going to be installed
+
E: Broken packages
+
 
+
Solution: the quickest solution is to skip the use of the cache cd or to have latest samba package installed before starting the installation.
+
 
+
* sometimes it's better to kill the network manager and add the network settings manually. I found that the network settings are overwritten when the installation of Linux MCE is finished. and you don't have internet connection anymore. This may lead to problems like the one above, with the samba package.
+
 
+
 
+
* if you are rebooting the system after installing LinuxMCE 1.1 and the system hangs up at "'''Running local boot scripts (/etc/rc.local) [ OK]'''"
+
  
Solution: rename kdm.saved from /etc/init.d to kdm and then reboot.
+
*[[Known_Issues_LinuxMCE10|Known issues with LinuxMCE 1.0]]

Latest revision as of 23:47, 1 April 2010

Known issues with LinuxMCE 0810

Known issues with LinuxMCE 0710

Known issues with LinuxMCE 0704

Known issues with LinuxMCE 1.1

Known issues with LinuxMCE 1.0