Difference between revisions of "Known Issues"

From LinuxMCE
Jump to: navigation, search
(Removed Spam)
 
(30 intermediate revisions by 7 users not shown)
Line 1: Line 1:
 +
[[Category: Known Issues]]
 +
{| align="right"
 +
  | __TOC__
 +
  |}
 +
 +
== Known issues with LinuxMCE 0810 ==
 +
*[[LinuxMCE-0810_beta|Known issues with 0810 Beta]]
  
 
== Known issues with LinuxMCE 0710 ==
 
== Known issues with LinuxMCE 0710 ==
Check this page [[KnownIssues_0710]]
+
*[[Known_Issues_0710|Known issues with 0710 RC2]]
 
+
*[[Known_Issues_0710_RC1|Known issues with 0710 RC1]]
 +
*[[Known_Issues_0710_Beta4|Known issues with 0710 Beta4]]
 +
*[[Known_Issues_0710_Beta3|Known issues with 0710 Beta3]]
  
 
== Known issues with LinuxMCE 0704 ==
 
== Known issues with LinuxMCE 0704 ==
  
Be sure to read [[Video#network]] because if you don't enable your network connection you won't have gallery art or be able to add extra software.
+
*[[Known_Issues_0704|Known issues with 0704]]
  
The QuickInstall DVD is not correctly handling an installation with a single network interface card.  If you have only 1 network interface card, then as explained in [[Video#network]] when you go to test your network, go into the Admin site.  Choose Advanced, Configuration, Devices.  Click the 'Core' in the left device tree.  Scroll down to 'Network Settings', and carefully edit that line changing the text that says "eth1" to instead say "eth0:0".  Then save the changes on that page.  Now go to Advanced, Network, Network Settings.  If you're using a static IP specify it now.  Whether or not you made any changes, click the update button which will cause it to reset your network.  Confirm you now have an internet connection.  The network settings should show that eth0 is your normal network (dhcp or static), and eth1 is 192.168.80.1.  If you don't want LinuxMCE to be your DHCP server, you can disable that option here.
+
== Known issues with LinuxMCE 1.1 ==
  
LMCE 0704 will not use windows shares with spaces in them, e.g. "DISK 1".
+
*[[Known_Issues_11Beta|Known issues with LinuxMCE 1.1 Beta]]
 
+
== Known issues with LinuxMCE 1.1 Beta ==
+
 
+
* if you get the following error:
+
 
+
pluto-dcerouter: Depends: pluto-confirm-dependencies (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-confirm-dependencies (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-createdevice (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-createdevice (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-install-scripts (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-install-scripts (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-local-database (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-local-database (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-std-plugins (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-std-plugins (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-system-database (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-system-database (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-website-admin (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-website-admin (< 2.0.0.45) but it is not going to be installed
+
                  Depends: pluto-boot-scripts (>= 2.0.0.44) but it is not going to be installed
+
                  Depends: pluto-boot-scripts (< 2.0.0.45) but it is not going to be installed
+
                  PreDepends: samba but it is not going to be installed
+
E: Broken packages
+
 
+
Solution: the quickest solution is to skip the use of the cache cd or to have latest samba package installed before starting the installation.
+
 
+
* sometimes it's better to kill the network manager and add the network settings manually. I found that the network settings are overwritten when the installation of Linux MCE is finished. and you don't have internet connection anymore. This may lead to problems like the one above, with the samba package.
+
 
+
 
+
* if you are rebooting the system after installing LinuxMCE 1.1 and the system hangs up at "'''Running local boot scripts (/etc/rc.local) [ OK]'''"
+
 
+
Solution: rename kdm.saved from /etc/init.d to kdm and then reboot.
+
  
 
== Known issues with LinuxMCE 1.0 ==
 
== Known issues with LinuxMCE 1.0 ==
  
It is best to install version 1.0 on a separate box, rather than your main Ubuntu system because of the following issues:
+
*[[Known_Issues_LinuxMCE10|Known issues with LinuxMCE 1.0]]
 
+
* The installer is messing up Ubuntu's xorg.conf file by removing the nvidia driver and replacing it with vesa.  This was actually a necessary hack that got forgotten about.  There is a bug in the nVidia drivers (it has been reported) that causes them to crash when two X sessions are running and try to open the same card.  Using the 'nv' driver on one and the 'nvidia' on the other still doesn't work, but using vesa on one and nvidia on the other does.  So the hack changes Ubuntu's xorg.conf from nVidia to Vesa.  If you install a dedicated LinuxMCE box this isn't an issue, but it can be a problem when you are a Ubuntu user and want better performance on your Ubuntu desktop than the vesa driver allows.
+
 
+
*  The installer will revert the Ubuntu sources.list back to the default, removing any non-standard repositories, when it does the upgrade before installing itself.
+
 
+
*  As mentioned in other places, the scripts carried from Pluto were written to be run on a dedicated system and 'take over' completely.  It was a huge task just getting LinuxMCE 1.0 out the door, and the Ubuntu integration is still a work in progress and the scripts are still too invasive.  If this is a dedicated system, or if you're not a Linux user, this is perhaps still a good thing because you'll never need to touch your configuration files: LinuxMCE will setup the dhcp server, samba network shares, network settings, and so on.  But, if you are a Ubuntu user, be warned that it will override some of your settings until we get the Ubuntu integration improved.
+
 
+
Additional issues:
+
 
+
*  Most of the problems reported so far are caused by using UI2, which requires OpenGL, on video cards without good Linux OpenGL support.  The solution is to use UI1 instead.  nVidia 6xxx and higher are preferred and will run UI2 with the 3d effects and alpha blending.
+
 
+
*  A bug in the media browser was identified that is causing it to run very slow and consume a lot of memory.  A 1.01 patch will be out soon.
+
 
+
*  In the haste to release the updated LinuxMCE 1.0 that didn't use the website for downloading the software after the Digg story brought the server down, there was a sloppy error building the package for the Windows binaries.  Most of them are empty.  This means the Windows orbiter that runs on web pads, pda's and ms smart phones, as well as some other windows applets which are also on the download page in your Core's admin web site, are missing.
+
 
+
* Some of the users reported having broken packages during the installation of  LinuxMCE, usually 'pluto-orbiter' package. This could happen from a number of reasons. We have identified a few of them, such as:
+
- the vim package cannot be installed because of a conflict at 'vim-common'. For details on how to fix that, please follow:  [http://wiki.linuxmce.com/index.php/Installer_Problems]
+
- The Ubuntu repositories are sometimes unavailable. You should try reinstalling, or installing the packages by hand
+

Latest revision as of 23:47, 1 April 2010

Known issues with LinuxMCE 0810

Known issues with LinuxMCE 0710

Known issues with LinuxMCE 0704

Known issues with LinuxMCE 1.1

Known issues with LinuxMCE 1.0