Known Issues

From LinuxMCE
Revision as of 13:48, 4 April 2007 by Juliet (Talk | contribs)

Jump to: navigation, search

Known issues with LinuxMCE 1.0

It is best to install version 1.0 on a separate box, rather than your main Ubuntu system because of the following issues:

  • The installer is messing up Ubuntu's xorg.conf file by removing the nvidia driver and replacing it with vesa. This was actually a necessary hack that got forgotten about. There is a bug in the nVidia drivers (it has been reported) that causes them to crash when two X sessions are running and try to open the same card. Using the 'nv' driver on one and the 'nvidia' on the other still doesn't work, but using vesa on one and nvidia on the other does. So the hack changes Ubuntu's xorg.conf from nVidia to Vesa. If you install a dedicated LinuxMCE box this isn't an issue, but it can be a problem when you are a Ubuntu user and want better performance on your Ubuntu desktop than the vesa driver allows.
  • The installer will revert the Ubuntu sources.list back to the default, removing any non-standard repositories, when it does the upgrade before installing itself.
  • As mentioned in other places, the scripts carried from Pluto were written to be run on a dedicated system and 'take over' completely. It was a huge task just getting LinuxMCE 1.0 out the door, and the Ubuntu integration is still a work in progress and the scripts are still too invasive. If this is a dedicated system, or if you're not a Linux user, this is perhaps still a good thing because you'll never need to touch your configuration files: LinuxMCE will setup the dhcp server, samba network shares, network settings, and so on. But, if you are a Ubuntu user, be warned that it will override some of your settings until we get the Ubuntu integration improved.

Additional issues:

  • Most of the problems reported so far are caused by using UI2, which requires OpenGL, on video cards without good Linux OpenGL support. The solution is to use UI1 instead. nVidia 6xxx and higher are preferred and will run UI2 with the 3d effects and alpha blending.
  • A bug in the media browser was identified that is causing it to run very slow and consume a lot of memory. A 1.01 patch will be out soon.
  • In the haste to release the updated LinuxMCE 1.0 that didn't use the website for downloading the software after the Digg story brought the server down, there was a sloppy error building the package for the Windows binaries. Most of them are empty. This means the Windows orbiter that runs on web pads, pda's and ms smart phones, as well as some other windows applets which are also on the download page in your Core's admin web site, are missing.
  • Some of the users reported having broken packages during the installation of LinuxMCE, usually 'pluto-orbiter' package. This could happen from a number of reasons. We have identified a few of them, such as:

- the vim package cannot be installed because of a conflict at 'vim-common'. For details on how to fix that, please follow: [1] - The Ubuntu repositories are sometimes unavailable. You should try reinstalling, or installing the packages by hand