Difference between revisions of "Odroid XU4"

From LinuxMCE
Jump to: navigation, search
(Created page with "=== General === The ODROID-XU4 is powered by ARM® big.LITTLE™ technology, the Heterogeneous Multi-Processing (HMP) solution. It offers open source support, the board can r...")
 
Line 19: Line 19:
 
*Use the odroid-utility to resize the sdcard or eMMC card you are booting from so all space is available:
 
*Use the odroid-utility to resize the sdcard or eMMC card you are booting from so all space is available:
 
  odroid-utility.sh  
 
  odroid-utility.sh  
*Add the following linuxmce repository definitions to sources.list:
+
*Add the following linuxmce repository definitions to /etc/apt/sources.list:
 
  deb http://deb.linuxmce.org/ubuntu/ trusty  main
 
  deb http://deb.linuxmce.org/ubuntu/ trusty  main
 
  deb http://deb.linuxmce.org/ trusty  main
 
  deb http://deb.linuxmce.org/ trusty  main

Revision as of 19:07, 1 December 2015

General

The ODROID-XU4 is powered by ARM® big.LITTLE™ technology, the Heterogeneous Multi-Processing (HMP) solution. It offers open source support, the board can run various flavors of Linux, including the latest Ubuntu 15.04 and Android 4.4 KitKat and 5.0 Lollipop. The XU4 is fully software compatible with XU3. The hardware specifications:

  • Samsung Exynos5422 Cortex™-A15 2Ghz and Cortex™-A7 Octa core CPUs
  • Mali-T628 MP6(OpenGL ES 3.0/2.0/1.1 and OpenCL 1.1 Full profile)
  • 2Gbyte LPDDR3 RAM PoP stacked
  • eMMC5.0 HS400 Flash Storage
  • 2 x USB 3.0 Host, 1 x USB 2.0 Host
  • Gigabit Ethernet port
  • HDMI 1.4a for display
  • Size : 82 x 58 x 22 mm approx.(including cooling fan)

Installing a LinuxMCE Core on the Odroid XU4

  • Connect a USB NIC to your XU4.
  • Download the latest Ubuntu 14.04 Server image for XU4/XU3 here: - http://odroid.in/ubuntu_14.04lts/
  • Install the Ubuntu 14.04 Server image onto your Odroid XU4 device.
  • Use the odroid-utility to resize the sdcard or eMMC card you are booting from so all space is available:
odroid-utility.sh 
  • Add the following linuxmce repository definitions to /etc/apt/sources.list:
deb http://deb.linuxmce.org/ubuntu/ trusty  main
deb http://deb.linuxmce.org/ trusty  main
deb http://ports.ubuntu.com/ trusty  main restricted universe multiverse
deb http://ports.ubuntu.com/ trusty-updates  main restricted universe multiverse
deb http://ports.ubuntu.com/ trusty-backports  main restricted universe multiverse
deb http://ports.ubuntu.com/ trusty-security  main restricted universe multiverse
  • Retrieve the updated package lists:
apt-get update
  • Install LinuxMCE as a Core only:
DEBIAN_FRONTEND=non-interactive apt-get install lmce-core -y --allow-unauthenticated
  • Reboot to allow setup and firstboot to occur.
  • Update and upgrade to the latest:
apt-get update && apt-get dist-upgrade
  • Reboot:
  • At minimum create a user, a room and choose a PVR system
  • Be very patient and have fun