QOrbiter Targets

From LinuxMCE
Revision as of 22:19, 3 December 2012 by Buckle (Talk | contribs) (Windows RT)

Jump to: navigation, search

This page is meant as an overview, what targets exist for the qOrbiter, and what kind of requirements each of the targets has.

Linux

Linux is the main platform qOrbiter is developed on.

Qt lib version = 4.8.3

Relevant directories

qOrbiter_src/qml/desktop

Android

Android is the main target for smaller skins.

Qt lib version = 4.8.2 (necessitas)

Relevant directories

qOrbiter_src/qml/android
qOrbiter_src/android

Symbian

Symbian could be target. We need developers for this.

Qt lib version = 4.8.x (latest 4.x should always be usable. Details on QtProject

Relevant directories

no specific QML created as of yet posde

Windows x86

Windows x86 is being worked on, without many details.

Qt lib version = 4.8.x (latest 4.x should be usable)

Relevant directories

qOrbiter_src/qml/desktop

Windows RT

Windows RT could be a target, but there are no devs for it atm.

In order to work on WinRT, QOrbiter will need to be made into a Windows Store app. There are a few dependency hurdles that will need to be cleared in order for that to happen.

  • QT libs needs to be ported to WinRT.
    • Status of that project can be found here: [1]
  • DCE and other supporting LinuxMCE libs need to be ported to WinRT.
    • Not all win32 apis are available from the Windows Store app sandbox. Threading and sockets come to mind. Significant re-write and/or shims may be necessary.


Qt lib version = QT5

iOS

iOS is an important target, but atm there is no release of a Qt lib that we can use for it.

MacOSX

MacOSX could be a target, but there is nothing available atm.