ShuttleX50V2

From LinuxMCE
Revision as of 05:35, 8 September 2010 by Bongowongo (Talk | contribs) (Other remarks, needed investigation)

Jump to: navigation, search
Version Status Date Updated Updated By
710 Unknown N/A N/A
810 Works, not pnp 8th September 2010 BongoWongo
1004 Unknown N/A N/A
1204 Unknown N/A N/A
1404 Unknown N/A N/A
Usage Information

This page is compliant with 0810 Beta | Current status : working, not plug and play

Shuttle X50 V2 [1]

It is a 15,4 inch touchscreen with an atom processor, with builtin camera, microphone and speakers. Ideal for a kitchen situation.

How to get it working.

Diskless Boot

  1. Unrecognized NIC

The driver for the JMicron JMC250 PCI Express Gigabit Ethernet controller needs to be first installed, before the MD will netboot. Download the file jme-1.0.5.tbz2 which contains the driver from ftp://jmicron.com.tw/jmc2xx/Linux/

Open a "terminal" and type the following

$ tar xjvf jme-1.0.5.tbz2
$ cd jme-1.0.5
$ make install

copy the module to the running kernel

$ cp jme.ko /lib/modules/2.6.27-17-generic/kernel/drivers/net/

To get a NIC to work, you have to modify a file, type the following in "terminal"

$ sudo <editor-of-choice> /etc/initramfs-tools-interactor/modules

and add a single line for your NICs kernel module. In the above case the name of the module is

jme

After adding the above line (and saving the change of course), you have to recreate the initial ramdisk.

/usr/pluto/bin/Diskless_BuildDefaultImage.sh

or maybe

mkinitramfs -d /etc/initramfs-tools-interactor/ -o /tftpboot/default/initrd

is enough.

This will create a new initial ramdisk for the first boot of new MDs containing the jme module. Now, the first boot of the diskless MD will succeed and a new diskless media director will be created.

  1. ACPI

Turn it off

Needs more info

Touchscreen

Used a keyboard to go through all of the wizards, went into KDE Desktop, installed latest Egalax drivers. Touchscreen works, but has the tendency to double tap. Ignore first event, does not work.

Needs more info

Other remarks, needed investigation

  1. Could not get a higher resolution than 640x480, need to configure videocard proper. Driver/Xorg.conf possible solution => install intel ppa drivers

sudo apt-get remove -purge nvidia* http://forum.linuxmce.org/index.php?topic=9149.0

  1. Makes strange dark beep when booting
  2. As I do not use it and I was in troubleshooting modus, I disconnected the wifi, so cannot comment on it
  3. Webcam and microphone are not tested yet

This page is a work in progress