Difference between revisions of "Sony KDL-46W4500"

From LinuxMCE
Jump to: navigation, search
m
(Added info about 50Hz not working via PC input on Sony TVs- curse them!)
Line 4: Line 4:
 
I am using an '''European''' version this TV and will try to describe problems I have here.
 
I am using an '''European''' version this TV and will try to describe problems I have here.
  
Connected to a Nvidia 7300GT with an DVI to HDMI cable.
+
Connected to a Nvidia 7300GT with an DVI to HDMI cable.  
 +
 
 +
''NOTE that the 50 Hz modelines will probably not work if you try to connect to a non-HDMI port on the Sony TV (i.e. the PC input).  The Sony KDL-46WE5 which is supposed to be very similar to this model would not display 1920x1080 50Hz modelines when connected to the PC input on the TV.  This was using a VGA DB15 video cable attached to a DVI-DB15 converter (graphics card in my PC has 2xDVI ports).  Once an DVI-HDMI converter and HDMI cable was used instead the 50Hz modelines worked properly. The Sony manual has a single table which is for the PC and HDMI inputs- this would lead you to believe that PC input and the HDMI inputs all support the same graphics modes but they don't. (Indulis' experience)''
  
 
I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the folowing lines :
 
I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the folowing lines :

Revision as of 17:13, 5 January 2010


I am using an European version this TV and will try to describe problems I have here.

Connected to a Nvidia 7300GT with an DVI to HDMI cable.

NOTE that the 50 Hz modelines will probably not work if you try to connect to a non-HDMI port on the Sony TV (i.e. the PC input). The Sony KDL-46WE5 which is supposed to be very similar to this model would not display 1920x1080 50Hz modelines when connected to the PC input on the TV. This was using a VGA DB15 video cable attached to a DVI-DB15 converter (graphics card in my PC has 2xDVI ports). Once an DVI-HDMI converter and HDMI cable was used instead the 50Hz modelines worked properly. The Sony manual has a single table which is for the PC and HDMI inputs- this would lead you to believe that PC input and the HDMI inputs all support the same graphics modes but they don't. (Indulis' experience)

I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the folowing lines :

Option         "UseEDIDDpi" "false"
Option         "UseEDID" "true"
Modes           "1920x1080_50_1" "1920x1080_50_0" "1920x1080_50" "1920x1080" "1920x1080_50i"
VertRefresh     49-51

and rebooted. After that I had 50hz.

The line "1920x1080_50" uses the EDID information it gets of the TV and sets things up correctly. In the /var/log/Xorg.0.log you can then see that it chooses the right resolution.

"UseEDIDDpi" "false" is important, otherwise you will get very small unreadable characters.



Alternate solution (I used first).

I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf to the right 1080p@50hz Modeline i found in the HDTV list in the MythTV modeline database.

       # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
       ModeLine "1920x1080" 148.50 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync

And changed the VertRefresh to :

       VertRefresh     49-51

and rebooted. After that I had 50hz.


My latest xorg.conf


 Section "ServerLayout"
         Identifier      "XFree86 Configured"
         Screen    0     "Screen0"       0 0
         InputDevice     "Mouse0"        "CorePointer"
         InputDevice     "Keyboard0"     "CoreKeyboard"
 EndSection
 
 Section "Files"
         RgbPath         "/usr/X11R6/lib/X11/rgb"
         ModulePath      "/usr/lib/xorg/modules"
         FontPath        "/usr/share/fonts/X11"
         FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
         FontPath        "/usr/X11R6/lib/X11/fonts/Speedo/"
         FontPath        "/usr/X11R6/lib/X11/fonts/Type1/"
         FontPath        "/usr/X11R6/lib/X11/fonts/CID/"
         FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/"
         FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/"
 EndSection
 
 Section "Module"
         Load    "dbe"
         Load    "extmod"
         Load    "record"
         Load    "xtrap"
         Load    "speedo"
         Load    "type1"
         Load    "glx"
         Load    "int10"
         Load    "v4l"
 EndSection
 
 Section "InputDevice"
         Identifier      "Keyboard0"
         Driver          "keyboard"
         Option          "XkbLayout"     "dk"
         Option          "XkbVariant"    "basic"
         Option          "XkbModel"              "pc105"
 EndSection
 
 Section "InputDevice"
         Identifier      "Mouse0"
         Driver          "mouse"
         Option          "Protocol"              "auto"
         Option          "Device"                "/dev/input/mice"
         Option          "ZAxisMapping"  "4 5"
 EndSection
 
 Section "Monitor"
         Identifier      "Monitor0"
         VendorName      "Unknown Monitor Vendor"
         ModelName       "Unknown Monitor Model"
 
         # gtf 1920 1080 50
         #
         # 1920x1080 @ 25 Hz (EDID) HSync: 28.125 kHz
         # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
         # ORG Modeline  "1920x1080" 148.5 1920 1960 2016 2200 1080 1082 1088 1125
         # ORG VertRefresh       59-61
         # 1920x1080 @ 25 Hz (EDID) HSync: 28.125 kHz
         # ModeLine "1920x1080" 74.25 1920 2448 2492 2640 1080 1084 1089 1125 +HSync +VSync
         # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
         # ModeLine "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +HSync +VSync
         #
         # 1920x1080 @ 50 Hz (EDID) HSync: 28.125 kHz
         ModeLine "1920x1080_my50i" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +HSync +VSync Interlace
         #
         # From Powerstrip 1920x1080 @ 24hz
         # ModeLine "1920x1080" 74.250 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
         # From Powerstrip 1920x1080 @ 25hz
         # Xorg.log said 24,9hz / try adding some more
         # ModeLine "1920x1080" 77.142 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
         ModeLine "1920x1080_my25" 77.500 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
         # VertRefresh   24-26
         #
         # From Powerstrip 1920x1080 @ 50hz
         ModeLine "1920x1080_my50" 148.500 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
         # ModeLine "1920x1080_my50a" 148.750 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
         VertRefresh     24-51
         HorizSync       20-500
         # VertRefresh   49-51
 EndSection
 
 Section "Device"
         ### Available Driver options are:-
         ### Values: : integer, <f>: float, <bool>: "True"/"False",
         ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
         ### [arg]: arg optional
         #Option         "NoAccel"                               # [<bool>]
         #Option         "SWcursor"                              # [<bool>]
         #Option         "ColorKey"                              # <i>
         #Option         "CacheLines"                    # <i>
         #Option         "Dac6Bit"                               # [<bool>]
         #Option         "DRI"                                   # [<bool>]
         #Option         "NoDDC"                                 # [<bool>]
         #Option         "ShowCache"                             # [<bool>]
         #Option         "XvMCSurfaces"                  # <i>
         Identifier      "Card0"
         Driver          "nvidia"
         VendorName      "Unknown Vendor Name"
         BoardName       "Unknown Board Name"
         Option          "LinearAlloc"           "16384"
         #BusID          "PCI:0:2:0"
 #       Option          "NoDDC"                         "true"
    Option         "UseEDIDDpi" "false"
    ## Option         "UseEDIDFreqs" "false"
         Option "XvmcUsesTextures" "true"
         Option "renderAccel" "true"
         Option "NoDDCValue"
         ## Option "UseEDID" "false"
         Option "ExactModeTimingsDVI" "true"
         Option "NoLogo" "true"
         Option "NoBandWidthTest" "true"
         # Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
         Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
         Option "DynamicTwinView" "false"
         Option "UseEvents" "true"
         Option "AllowGLXWithComposite" "true"
         Option "AddARGBGLXVisuals" "true"
         Option          "ConnectedMonitor" "DFP"
 EndSection
 
 Section "Screen"
         Identifier      "Screen0"
         Device          "Card0"
         Monitor         "Monitor0"
         DefaultDepth    24
         SubSection "Display"
                 # Modes         "1920x1080"
                 Modes           "1920x1080_50_1" "1920x1080_50_0" "1920x1080_50" "1920x1080_my50"
                 # Modes         "1920x1080_my50a" "1920x1080_50" "1920x1080_50_0" "1920x1080"
                 #TESTED Modes           "1920x1080_50_0" "1920x1080_50i_0" "1920x1080_50i" "1920x1080_my50i" "1920x1080_my25" "1920x1080"
                 Virtual         1920 1080
         EndSubSection
    Option         "UseEDIDDpi" "false"
    ## Option         "UseEDIDFreqs" "false"
         Option "XvmcUsesTextures" "true"
         Option "renderAccel" "true"
         Option "NoDDCValue"
         ## Option "UseEDID" "false"
         Option "ExactModeTimingsDVI" "true"
         Option "NoLogo" "true"
         Option "NoBandWidthTest" "true"
         # Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
         Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
         Option "DynamicTwinView" "false"
         Option "UseEvents" "true"
         Option "AllowGLXWithComposite" "true"
         Option "AddARGBGLXVisuals" "true"
         Option  "TVStandard"    "1080p"
 EndSection
 
 Section "ServerFlags"
         Option  "AllowMouseOpenFail"    "true"
         Option  "BlankTime"             "0"
         Option  "StandbyTime"   "0"
         Option  "SuspendTime"   "0"
         Option  "OffTime"               "0"
         Option  "AIGLX"                 "Off"
 EndSection
 Section "Extensions"
         Option "Composite" "false"
         Option "RENDER" "true"
 EndSection