Difference between revisions of "Sony KDL-46W4500"

From LinuxMCE
Jump to: navigation, search
m
 
(9 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
[[Category: Hardware]]
 +
{{versioninfo|810Status=Working|810UpdatedDate=10th July 2012|810UpdatedBy=Viking}}
 
[[Category:Video]]
 
[[Category:Video]]
 
[[Category:Displays]]
 
[[Category:Displays]]
Line 4: Line 6:
 
I am using an '''European''' version this TV and will try to describe problems I have here.
 
I am using an '''European''' version this TV and will try to describe problems I have here.
  
Connected to a Nvidia 7300GT with an DVI to HDMI cable.  
+
Connected to a Nvidia 8400 GS with an DVI to HDMI cable.  
  
''NOTE that the 50 Hz modelines will probably not work if you try to connect to a non-HDMI port on the Sony TV (i.e. the PC input).  The Sony KDL-46WE5 (which is supposed to be very similar to this model) would not display 1920x1080 50Hz modelines when the PC was connected to the PC input on the TV.  This failure happened was using a VGA DB15 video cable attached to a DVI-DB15 converter - the graphics card in my PC has 2xDVI ports.  Once an DVI-HDMI converter and HDMI cable was used then the 50Hz modelines worked properly. The Sony manual has a single table for the graphics modes supported by the PC and HDMI inputs- this would lead you to believe that PC input and the HDMI inputs all support the same graphics modes but they don't. (Indulis' experience)''
 
  
I was not able to get the TV setup to 1080p with 50hz, so I chose 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the folowing lines :
+
'''10th July 2012 - Currently I am using the judderfree solution further down with 0810 '''
 +
 
 +
 
 +
I was not able to get the AV Wizard to setup the TV to 1080p with 50hz, so I setup 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the following lines :
  
 
  Option        "UseEDIDDpi" "false"
 
  Option        "UseEDIDDpi" "false"
Line 21: Line 25:
  
 
"UseEDIDDpi" "false" is important, otherwise you will get very small unreadable characters.
 
"UseEDIDDpi" "false" is important, otherwise you will get very small unreadable characters.
 +
 +
 +
 +
I did also start KDE and then start nvidia-settings. Then below OpenGL settings activated the checkbox next to "Sync to VBlank" so that it is used.
 +
 +
Then in MythTV (see here http://www.mythtv.org/wiki/VDPAU#Enabling_VDPAU_in_MythFrontend) under "Utilities -> Setup -> TV Settings -> Playback -> Playback Profiles (3/8)" setup "VDPAU Normal"
 +
 +
 +
Update 20.07.2012 for Judderfree is this also needed :
 +
http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering
 +
Change Option "Composite" "true" in /etc/X11/xorg.conf to '''"Disable"''':
 +
 +
  Section "Extensions"
 +
      Option "Composite" "Disable"
 +
  EndSection
 +
 +
----
 +
 +
 +
== Judder free TV and Video with MythTV and MythTV video plugin ==
 +
 +
'''10th July 2012 - This is the CURRENT solution I am using with 0810 '''
 +
 +
 +
Using the description from here :
 +
http://www.mythtv.org/wiki/User_Manual:JudderFree
 +
 +
'''IMPORTANT is in your xorg.conf to change the Option "DynamicTwinView" to "true" !!!''' That is the option that lets you choose ALL the refresh rates, also the 23.97 !
 +
 +
I did setup all the needed resolutions and changed MythTV to change the resolution as described in the link above. '''The xorg.conf from below works with that!!!'''
 +
 +
That way MýthTV's Video plugin will change the refresh rate to the right typ, no matter what kind of material you are playing. Execpt for PAL DVD's , they are for some reason set to NTSC 59.96 rate. I have no idea why at the monent.
 +
 +
I have still setup the VDPAU things above in mythtv and "vsync to blanc" nvidia-settings !!
 +
 +
And this is also needed :
 +
http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering
 +
Change Option "Composite" "true" in /etc/X11/xorg.conf to '''"Disable"''':
 +
 +
  Section "Extensions"
 +
      Option "Composite" "Disable"
 +
  EndSection
 +
  
 
----
 
----
  
  
Alternate solution (I used first).
+
== Alternate solution (I used first) ==
  
 
I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf to the right 1080p@50hz Modeline i found in the HDTV list in the MythTV modeline database.
 
I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf to the right 1080p@50hz Modeline i found in the HDTV list in the MythTV modeline database.
Line 39: Line 86:
 
----
 
----
  
My latest xorg.conf
+
== My latest xorg.conf ==
  
  
  Section "ServerLayout"
+
    Section "ServerLayout"
          Identifier     "XFree86 Configured"
+
    Identifier "XFree86 Configured"
          Screen   0     "Screen0"       0 0
+
    Screen   0 "Screen0" 0 0
          InputDevice     "Mouse0"       "CorePointer"
+
    InputDevice "Mouse0" "CorePointer"
          InputDevice     "Keyboard0"     "CoreKeyboard"
+
    InputDevice "Keyboard0" "CoreKeyboard"
  EndSection
+
    EndSection
 
+
   
  Section "Files"
+
    Section "Files"
          RgbPath         "/usr/X11R6/lib/X11/rgb"
+
    # RgbPath "/usr/X11R6/lib/X11/rgb"
          ModulePath     "/usr/lib/xorg/modules"
+
    ModulePath "/usr/lib/xorg/modules"
          FontPath       "/usr/share/fonts/X11"
+
    FontPath "/usr/share/fonts/X11"
          FontPath       "/usr/X11R6/lib/X11/fonts/misc/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
          FontPath       "/usr/X11R6/lib/X11/fonts/Speedo/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
          FontPath       "/usr/X11R6/lib/X11/fonts/Type1/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
          FontPath       "/usr/X11R6/lib/X11/fonts/CID/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/CID/"
          FontPath       "/usr/X11R6/lib/X11/fonts/75dpi/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
          FontPath       "/usr/X11R6/lib/X11/fonts/100dpi/"
+
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
  EndSection
+
    EndSection
 
+
   
  Section "Module"
+
    Section "Module"
          Load   "dbe"
+
    Load "dbe"
          Load   "extmod"
+
    Load "extmod"
          Load   "record"
+
    Load "record"
          Load   "xtrap"
+
    Load "xtrap"
          Load   "speedo"
+
    Load "speedo"
          Load   "type1"
+
    Load "type1"
          Load   "glx"
+
    Load "glx"
          Load   "int10"
+
    Load "int10"
          Load   "v4l"
+
    Load "v4l"
  EndSection
+
    EndSection
 
+
   
  Section "InputDevice"
+
    Section "InputDevice"
          Identifier     "Keyboard0"
+
    Identifier "Keyboard0"
          Driver         "keyboard"
+
    Driver "keyboard"
          Option         "XkbLayout"     "dk"
+
    Option "XkbLayout" "us"
          Option         "XkbVariant"   "basic"
+
    Option "XkbVariant" "basic"
          Option         "XkbModel"             "pc105"
+
    Option "XkbModel" "pc105"
  EndSection
+
    EndSection
 
+
   
  Section "InputDevice"
+
    Section "InputDevice"
          Identifier     "Mouse0"
+
    Identifier "Mouse0"
          Driver         "mouse"
+
    Driver "mouse"
          Option         "Protocol"             "auto"
+
    Option "Protocol" "auto"
          Option         "Device"               "/dev/input/mice"
+
    Option "Device" "/dev/input/mice"
          Option         "ZAxisMapping" "4 5"
+
    Option "ZAxisMapping" "4 5"
  EndSection
+
    EndSection
 
+
   
  Section "Monitor"
+
    Section "Monitor"
          Identifier     "Monitor0"
+
    Identifier "Monitor0"
          VendorName     "Unknown Monitor Vendor"
+
    VendorName "Sony"
          ModelName       "Unknown Monitor Model"
+
    ModelName "46"
 
+
    ## HorizSync 20-500
          # gtf 1920 1080 50
+
    # 1920x1080 @ 50 Hz (EDID) HSync: 28.125 kHz
          #
+
    ## VertRefresh 49-51
          # 1920x1080 @ 25 Hz (EDID) HSync: 28.125 kHz
+
    ## ModeLine "1920x1080_my50i" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +HSync +VSync Interlace
          # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
+
            # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
          # ORG Modeline  "1920x1080" 148.5 1920 1960 2016 2200 1080 1082 1088 1125
+
            ## ModeLine "1920x1080_my50" 148.50 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
          # ORG VertRefresh       59-61
+
   
          # 1920x1080 @ 25 Hz (EDID) HSync: 28.125 kHz
+
    # 1920x1080p @ 50Hz (EIA/CEA-861B)  
          # ModeLine "1920x1080" 74.25 1920 2448 2492 2640 1080 1084 1089 1125 +HSync +VSync
+
    ModeLine "1920x1080@50" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
          # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
+
    # 1920x1080p @ 60Hz (EIA/CEA-861B)
          # ModeLine "1920x1080" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +HSync +VSync
+
    ModeLine "1920x1080@60" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
          #
+
    # 1920x1080p @ 24Hz (EIA/CEA-861B)
          # 1920x1080 @ 50 Hz (EDID) HSync: 28.125 kHz
+
    ModeLine "1920x1080@24" 74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
          ModeLine "1920x1080_my50i" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +HSync +VSync Interlace
+
    # 1920x1080p @ 23.976Hz (EIA/CEA-861B)
          #
+
    ModeLine "1920x1080@23.976" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
          # From Powerstrip 1920x1080 @ 24hz
+
    # 1920x1080i @ 50Hz (EIA/CEA-861B)
          # ModeLine "1920x1080" 74.250 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
+
    Modeline "1920x1080@50i" 74.250 1920 2448 2492 2640 1080 1085 1095 1125 +hsync +vsync Interlace
          # From Powerstrip 1920x1080 @ 25hz
+
    # 1920x1080i @ 60Hz (EIA/CEA-861B)
          # Xorg.log said 24,9hz / try adding some more
+
    Modeline "1920x1080@60i" 74.250 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync interlace
          # ModeLine "1920x1080" 77.142 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
+
    # 1920x1080p @ 59.94Hz (EIA/CEA-861B)
          ModeLine "1920x1080_my25" 77.500 1920 2560 2608 2752 1080 1084 1089 1125 +HSync +VSync
+
    ModeLine "1920x1080@59.94" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
          # VertRefresh  24-26
+
    # 1920x1080i @ 59.94Hz (EIA/CEA-861B)
          #
+
    Modeline "1920x1080@59.94i" 74.175 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync Interlace
          # From Powerstrip 1920x1080 @ 50hz
+
    # 1920x1080p @ 25Hz (EIA/CEA-861B)
          ModeLine "1920x1080_my50" 148.500 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
+
    ModeLine "1920x1080@25" 74.250 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
          # ModeLine "1920x1080_my50a" 148.750 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
+
    # 1920x1080p @ 29.97Hz (EIA/CEA-861B)
          VertRefresh    24-51
+
    ModeLine "1920x1080@29.97" 74.175 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
          HorizSync       20-500
+
    # 1920x1080p @ 30Hz (EIA/CEA-861B)
          # VertRefresh   49-51
+
    ModeLine "1920x1080@30" 74.250 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
  EndSection
+
    HorizSync 20.0 - 150.0
 
+
    VertRefresh     23.0 - 90.0
  Section "Device"
+
    Option "ExactModeTimingsDVI" "True"
          ### Available Driver options are:-
+
    Option "UseEDIDFreqs" "FALSE"
          ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
+
    Option "UseEDIDDpi" "FALSE"
          ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
+
    #!# Option "ModeValidation" "NoEdidModes"
          ### [arg]: arg optional
+
    EndSection
          #Option         "NoAccel"                               # [<bool>]
+
   
          #Option         "SWcursor"                             # [<bool>]
+
    Section "Device"
          #Option         "ColorKey"                             # <i>
+
    ### Available Driver options are:-
          #Option         "CacheLines"                   # <i>
+
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
          #Option         "Dac6Bit"                               # [<bool>]
+
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
          #Option         "DRI"                                   # [<bool>]
+
    ### [arg]: arg optional
          #Option         "NoDDC"                                 # [<bool>]
+
    #Option "NoAccel" # [<bool>]
          #Option         "ShowCache"                             # [<bool>]
+
    #Option "SWcursor" # [<bool>]
          #Option         "XvMCSurfaces"                 # <i>
+
    #Option "ColorKey" # <i>
          Identifier     "Card0"
+
    #Option "CacheLines" # <i>
          Driver         "nvidia"
+
    #Option "Dac6Bit" # [<bool>]
          VendorName     "Unknown Vendor Name"
+
    #Option "DRI" # [<bool>]
          BoardName       "Unknown Board Name"
+
    #Option "NoDDC" # [<bool>]
          Option         "LinearAlloc"           "16384"
+
    #Option "ShowCache" # [<bool>]
          #BusID         "PCI:0:2:0"
+
    #Option "XvMCSurfaces" # <i>
  #       Option         "NoDDC"                         "true"
+
    Identifier "Card0"
    Option         "UseEDIDDpi" "false"
+
    Driver "nvidia"
    ## Option         "UseEDIDFreqs" "false"
+
    VendorName "Unknown Vendor Name"
          Option "XvmcUsesTextures" "true"
+
    BoardName "Unknown Board Name"
          Option "renderAccel" "true"
+
    Option "LinearAlloc" "16384"
          Option "NoDDCValue"
+
    #BusID "PCI:0:2:0"
          ## Option "UseEDID" "false"
+
    # Option "NoDDC" "true"
          Option "ExactModeTimingsDVI" "true"
+
    Option "XvmcUsesTextures" "true"
          Option "NoLogo" "true"
+
    Option "renderAccel" "true"
          Option "NoBandWidthTest" "true"
+
    Option "NoDDCValue"
          # Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
+
    # Option "UseEDID" "false"
          Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
+
    Option "UseEDID" "true"
          Option "DynamicTwinView" "false"
+
            Option "UseEDIDDpi" "false"
          Option "UseEvents" "true"
+
    ## Option         "TripleBuffer" "True"
          Option "AllowGLXWithComposite" "true"
+
    Option "ExactModeTimingsDVI" "true"
          Option "AddARGBGLXVisuals" "true"
+
    Option "NoLogo" "true"
          Option         "ConnectedMonitor" "DFP"
+
    Option "NoBandWidthTest" "true"
  EndSection
+
    Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes,NoEdidModes"
 
+
    ## Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
  Section "Screen"
+
   
          Identifier     "Screen0"
+
    Option "DynamicTwinView" "true"
          Device         "Card0"
+
    Option "UseEvents" "true"
          Monitor         "Monitor0"
+
    ## CJA Maybe remove ?
          DefaultDepth   24
+
    Option "AllowGLXWithComposite" "true"
          SubSection "Display"
+
    Option "AddARGBGLXVisuals" "true"
                  # Modes         "1920x1080"
+
    Option "ConnectedMonitor" "DFP"
                  Modes           "1920x1080_50_1" "1920x1080_50_0" "1920x1080_50" "1920x1080_my50"
+
    EndSection
                  # Modes         "1920x1080_my50a" "1920x1080_50" "1920x1080_50_0" "1920x1080"
+
   
                  #TESTED Modes           "1920x1080_50_0" "1920x1080_50i_0" "1920x1080_50i" "1920x1080_my50i" "1920x1080_my25" "1920x1080"
+
    Section "Screen"
                  Virtual        1920 1080
+
    Identifier "Screen0"
          EndSubSection
+
    Device "Card0"
    Option        "UseEDIDDpi" "false"
+
    Monitor "Monitor0"
    ## Option        "UseEDIDFreqs" "false"
+
    DefaultDepth 24
          Option "XvmcUsesTextures" "true"
+
    Option     "FlatPanelProperties" "Scaling = Native"
          Option "renderAccel" "true"
+
    Option     "TwinView" "0"
          Option "NoDDCValue"
+
    SubSection "Display"
          ## Option "UseEDID" "false"
+
    ## Modes "1920x1080_50i" "1920x1080_50i_0" "1920x1080_my50i"
          Option "ExactModeTimingsDVI" "true"
+
    ## Virtual 1920 1080
          Option "NoLogo" "true"
+
    Depth    24
          Option "NoBandWidthTest" "true"
+
   
          # Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
+
    Modes "1920x1080@50" "1920x1080@60" "1920x1080@24" "1920x1080@23.976" "1920x1080@50i"
          Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
+
    Modes "1920x1080@60i" "1920x1080@59.94" "1920x1080@59.94i"
          Option "DynamicTwinView" "false"
+
   
          Option "UseEvents" "true"
+
    ## Modes "1920x1080@50i" "1920x1080@50" "1920x1080@60" "1920x1080@24" "1920x1080@23.976"
          Option "AllowGLXWithComposite" "true"
+
    ## Modes "1920x1080@60i" "1920x1080@59.94" "1920x1080@59.94i"
          Option "AddARGBGLXVisuals" "true"
+
    # Modes "1920x1080@25" "1920x1080@29.97" "1920x1080@30"
          Option "TVStandard"   "1080p"
+
    EndSubSection
  EndSection
+
    Option "XvmcUsesTextures" "true"
 
+
    Option "renderAccel" "true"
  Section "ServerFlags"
+
    Option "NoDDCValue"
          Option "AllowMouseOpenFail"   "true"
+
    # Option "UseEDID" "false"
          Option  "BlankTime"             "0"
+
    Option "UseEDID" "true"
          Option "StandbyTime"   "0"
+
            Option "UseEDIDDpi" "false"
          Option "SuspendTime"   "0"
+
    Option "ExactModeTimingsDVI" "true"
          Option "OffTime"               "0"
+
    Option "NoLogo" "true"
          Option "AIGLX"                 "Off"
+
    Option "NoBandWidthTest" "true"
  EndSection
+
    Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes,NoEdidModes"
  Section "Extensions"
+
    ## Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
          Option "Composite" "false"
+
    Option "DynamicTwinView" "true"
          Option "RENDER" "true"
+
    Option "UseEvents" "true"
  EndSection
+
    ## CJA Maybe remove ?
 +
    Option "AllowGLXWithComposite" "true"
 +
    Option "AddARGBGLXVisuals" "true"
 +
    Option "TVStandard" "1080p (16:9)"
 +
    EndSection
 +
   
 +
    Section "ServerFlags"
 +
    Option "AllowMouseOpenFail" "true"
 +
    Option  "AutoAddDevices" "false"
 +
    Option "BlankTime" "0"
 +
    Option "StandbyTime" "0"
 +
    Option "SuspendTime" "0"
 +
    Option "OffTime" "0"
 +
    Option "AIGLX" "Off"
 +
    EndSection
 +
    Section "ServerFlags"
 +
    Option "AutoAddDevices" "False"
 +
    EndSection
 +
    Section "ServerFlags"
 +
    Option "AutoAddDevices" "False"
 +
    EndSection
 +
    Section "ServerFlags"
 +
    Option "AutoAddDevices" "False"
 +
    EndSection
 +
    Section "ServerFlags"
 +
    Option "AutoAddDevices" "False"
 +
    EndSection
 +
    Section "Extensions"
 +
    Option "Composite" "false"
 +
    Option "RENDER" "true"
 +
    EndSection
 +
    Section "ServerFlags"
 +
    Option "AutoAddDevices" "False"
 +
    EndSection

Latest revision as of 21:02, 20 July 2012

Version Status Date Updated Updated By
710 Unknown N/A N/A
810 Working 10th July 2012 Viking
1004 Unknown N/A N/A
1204 Unknown N/A N/A
1404 Unknown N/A N/A
Usage Information

I am using an European version this TV and will try to describe problems I have here.

Connected to a Nvidia 8400 GS with an DVI to HDMI cable.


10th July 2012 - Currently I am using the judderfree solution further down with 0810


I was not able to get the AV Wizard to setup the TV to 1080p with 50hz, so I setup 1080p and 60hz. Then afterwards I changed the xorg.conf and changed/added the following lines :

Option         "UseEDIDDpi" "false"
Option         "UseEDID" "true"
Modes           "1920x1080_50_1" "1920x1080_50_0" "1920x1080_50" "1920x1080" "1920x1080_50i"
VertRefresh     49-51

and rebooted. After that I had 50hz.

The line "1920x1080_50" uses the EDID information it gets of the TV and sets things up correctly. In the /var/log/Xorg.0.log you can then see that it chooses the right resolution.

"UseEDIDDpi" "false" is important, otherwise you will get very small unreadable characters.


I did also start KDE and then start nvidia-settings. Then below OpenGL settings activated the checkbox next to "Sync to VBlank" so that it is used.

Then in MythTV (see here http://www.mythtv.org/wiki/VDPAU#Enabling_VDPAU_in_MythFrontend) under "Utilities -> Setup -> TV Settings -> Playback -> Playback Profiles (3/8)" setup "VDPAU Normal"


Update 20.07.2012 for Judderfree is this also needed : http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering Change Option "Composite" "true" in /etc/X11/xorg.conf to "Disable":

  Section "Extensions"
      Option "Composite" "Disable"
  EndSection


Judder free TV and Video with MythTV and MythTV video plugin

10th July 2012 - This is the CURRENT solution I am using with 0810


Using the description from here : http://www.mythtv.org/wiki/User_Manual:JudderFree

IMPORTANT is in your xorg.conf to change the Option "DynamicTwinView" to "true" !!! That is the option that lets you choose ALL the refresh rates, also the 23.97 !

I did setup all the needed resolutions and changed MythTV to change the resolution as described in the link above. The xorg.conf from below works with that!!!

That way MýthTV's Video plugin will change the refresh rate to the right typ, no matter what kind of material you are playing. Execpt for PAL DVD's , they are for some reason set to NTSC 59.96 rate. I have no idea why at the monent.

I have still setup the VDPAU things above in mythtv and "vsync to blanc" nvidia-settings !!

And this is also needed : http://www.mythtv.org/wiki/VDPAU#Tearing.2FStuttering Change Option "Composite" "true" in /etc/X11/xorg.conf to "Disable":

  Section "Extensions"
      Option "Composite" "Disable"
  EndSection




Alternate solution (I used first)

I was not able to get the TV setup to 1080p with 50hz, so I choosed 1080p and 60hz. Then afterwards I changed the xorg.conf to the right 1080p@50hz Modeline i found in the HDTV list in the MythTV modeline database.

       # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
       ModeLine "1920x1080" 148.50 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync

And changed the VertRefresh to :

       VertRefresh     49-51

and rebooted. After that I had 50hz.


My latest xorg.conf

   Section "ServerLayout"
   	Identifier	"XFree86 Configured"
   	Screen	  0	"Screen0"	0 0
   	InputDevice	"Mouse0"	"CorePointer"
   	InputDevice	"Keyboard0"	"CoreKeyboard"
   EndSection
   
   Section "Files"
   #	RgbPath		"/usr/X11R6/lib/X11/rgb"
   	ModulePath	"/usr/lib/xorg/modules"
   	FontPath	"/usr/share/fonts/X11"
   	FontPath	"/usr/X11R6/lib/X11/fonts/misc/"
   	FontPath	"/usr/X11R6/lib/X11/fonts/Speedo/"
   	FontPath	"/usr/X11R6/lib/X11/fonts/Type1/"
   	FontPath	"/usr/X11R6/lib/X11/fonts/CID/"
   	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/"
   	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/"
   EndSection
   
   Section "Module"
   	Load	"dbe"
   	Load	"extmod"
   	Load	"record"
   	Load	"xtrap"
   	Load	"speedo"
   	Load	"type1"
   	Load	"glx"
   	Load	"int10"
   	Load	"v4l"
   EndSection
   
   Section "InputDevice"
   	Identifier	"Keyboard0"
   	Driver		"keyboard"
   	Option		"XkbLayout"		"us"
   	Option		"XkbVariant"	"basic"
   	Option		"XkbModel"		"pc105"
   EndSection
   
   Section "InputDevice"
   	Identifier	"Mouse0"
   	Driver		"mouse"
   	Option		"Protocol"		"auto"
   	Option		"Device"		"/dev/input/mice"
   	Option		"ZAxisMapping"	"4 5"
   EndSection
   
   Section "Monitor"
   	Identifier	"Monitor0"
   	VendorName	"Sony"
   	ModelName	"46"
   	## HorizSync	20-500
   	# 1920x1080 @ 50 Hz (EDID) HSync: 28.125 kHz
   	## VertRefresh	49-51
   	## ModeLine "1920x1080_my50i" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +HSync +VSync Interlace
           # 1920x1080 @ 50 Hz (EDID) HSync: 56.25 kHz
           ## ModeLine "1920x1080_my50" 148.50 1920 2448 2496 2640 1080 1084 1089 1125 +HSync +VSync
   
   	# 1920x1080p @ 50Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@50" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080p @ 60Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@60" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080p @ 24Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@24" 74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080p @ 23.976Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@23.976" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080i @ 50Hz (EIA/CEA-861B) 
   	Modeline "1920x1080@50i" 74.250 1920 2448 2492 2640 1080 1085 1095 1125 +hsync +vsync Interlace 
   	# 1920x1080i @ 60Hz (EIA/CEA-861B) 
   	Modeline "1920x1080@60i" 74.250 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync interlace 
   	# 1920x1080p @ 59.94Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@59.94" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080i @ 59.94Hz (EIA/CEA-861B) 
   	Modeline "1920x1080@59.94i" 74.175 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync Interlace 
   	# 1920x1080p @ 25Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@25" 74.250 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080p @ 29.97Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@29.97" 74.175 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
   	# 1920x1080p @ 30Hz (EIA/CEA-861B) 
   	ModeLine "1920x1080@30" 74.250 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync 
   	HorizSync	20.0 - 150.0 
   	VertRefresh     23.0 - 90.0 
   	Option "ExactModeTimingsDVI" "True"
   	Option "UseEDIDFreqs" "FALSE"
   	Option "UseEDIDDpi" "FALSE"
   	#!# Option "ModeValidation" "NoEdidModes"
   EndSection
   
   Section "Device"
   	### Available Driver options are:-
   	### Values: : integer, <f>: float, <bool>: "True"/"False",
   	### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   	### [arg]: arg optional
   	#Option		"NoAccel"				# [<bool>]
   	#Option		"SWcursor"				# [<bool>]
   	#Option		"ColorKey"				# <i>
   	#Option		"CacheLines"			# <i>
   	#Option		"Dac6Bit"				# [<bool>]
   	#Option		"DRI"					# [<bool>]
   	#Option		"NoDDC"					# [<bool>]
   	#Option		"ShowCache"				# [<bool>]
   	#Option		"XvMCSurfaces"			# <i>
   	Identifier	"Card0"
   	Driver		"nvidia"
   	VendorName	"Unknown Vendor Name"
   	BoardName	"Unknown Board Name"
   	Option		"LinearAlloc"		"16384"
   	#BusID		"PCI:0:2:0"
   #	Option		"NoDDC"				"true"
   	Option "XvmcUsesTextures" "true"
   	Option "renderAccel" "true"
   	Option "NoDDCValue"
   	# Option "UseEDID" "false"
   	Option "UseEDID" "true"
           Option "UseEDIDDpi" "false"
   	## Option         "TripleBuffer" "True"
   	Option "ExactModeTimingsDVI" "true"
   	Option "NoLogo" "true"
   	Option "NoBandWidthTest" "true"
   	Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes,NoEdidModes"
   	## Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
   
   	Option "DynamicTwinView" "true"
   	Option "UseEvents" "true"
   	## CJA Maybe remove ?
   	Option "AllowGLXWithComposite" "true"
   	Option "AddARGBGLXVisuals" "true"
   	Option		"ConnectedMonitor" "DFP"
   EndSection
   
   Section "Screen"
   	Identifier	"Screen0"
   	Device		"Card0"
   	Monitor		"Monitor0"
   	DefaultDepth	24
   	Option	    "FlatPanelProperties" "Scaling = Native" 
   	Option	    "TwinView" "0" 
   	SubSection "Display"
   		## Modes		"1920x1080_50i" "1920x1080_50i_0" "1920x1080_my50i"
   		## Virtual		1920 1080
   		Depth     24 
   
   		Modes "1920x1080@50" "1920x1080@60" "1920x1080@24" "1920x1080@23.976" "1920x1080@50i"
   		Modes "1920x1080@60i" "1920x1080@59.94" "1920x1080@59.94i"
   
   		## Modes "1920x1080@50i" "1920x1080@50" "1920x1080@60" "1920x1080@24" "1920x1080@23.976"
   		## Modes "1920x1080@60i" "1920x1080@59.94" "1920x1080@59.94i"
   		# Modes "1920x1080@25" "1920x1080@29.97" "1920x1080@30"
   	EndSubSection
   	Option "XvmcUsesTextures" "true"
   	Option "renderAccel" "true"
   	Option "NoDDCValue"
   	# Option "UseEDID" "false"
   	Option "UseEDID" "true"
           Option "UseEDIDDpi" "false"
   	Option "ExactModeTimingsDVI" "true"
   	Option "NoLogo" "true"
   	Option "NoBandWidthTest" "true"
   	Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes,NoEdidModes"
   	## Option "ModeValidation" "NoVertRefreshCheck, NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
   	Option "DynamicTwinView" "true"
   	Option "UseEvents" "true"
   	## CJA Maybe remove ?
   	Option "AllowGLXWithComposite" "true"
   	Option "AddARGBGLXVisuals" "true"
   	Option	"TVStandard"	"1080p (16:9)"
   EndSection
   
   Section "ServerFlags"
   	Option	"AllowMouseOpenFail"	"true"
   	Option  "AutoAddDevices" 	"false"
   	Option	"BlankTime"		"0"
   	Option	"StandbyTime"	"0"
   	Option	"SuspendTime"	"0"
   	Option	"OffTime"		"0"
   	Option	"AIGLX"			"Off"
   EndSection
   Section "ServerFlags"
   	Option "AutoAddDevices" "False"
   EndSection
   Section "ServerFlags"
   	Option "AutoAddDevices" "False"
   EndSection
   Section "ServerFlags"
   	Option "AutoAddDevices" "False"
   EndSection
   Section "ServerFlags"
   	Option "AutoAddDevices" "False"
   EndSection
   Section "Extensions"
   	Option "Composite" "false"
   	Option "RENDER" "true"
   EndSection
   Section "ServerFlags"
   	Option "AutoAddDevices" "False"
   EndSection