Difference between revisions of "Troubleshooting"

From LinuxMCE
Jump to: navigation, search
 
(2 intermediate revisions by one other user not shown)
Line 24: Line 24:
 
== Internal and External networks swapped/not working ==
 
== Internal and External networks swapped/not working ==
 
[[Internal and External networks swapped/not working]]
 
[[Internal and External networks swapped/not working]]
 
== Orbiter cannot register with the router. please try again later. ==
 
I've seen this error before if the Asterisk was disabled:
 
go to the web admin page (type your core's IP in a browser) and from the upper menu, choose wizard / devices / core and see if the 'Asterisk' check-box is checked.
 
Once I've checked it again, at the next reload, the error disappeared.
 
But it might be another reason for it, too.
 
[http://forum.linuxmce.com/index.php?topic=1556.msg7023#msg7023 Forum Thread]
 
 
== E: Could not get lock /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable) ==
 
maybe this will do the trick
 
* Clean apt-get:
 
  apt-get clean
 
* Go to /var/lib/apt/lists and do
 
  mv lock lock.old.
 
* then , rerun the installer.
 
[http://forum.linuxmce.com/index.php?topic=1895.msg8621#msg8621 Forum Thread]
 
 
 
== How to change LMCE's DHCP settings ==
 
== How to change LMCE's DHCP settings ==
 
Go to '''[[LinuxMCE Admin Website]]-->Advanced-->Network-->[[Network Settings]]'''
 
Go to '''[[LinuxMCE Admin Website]]-->Advanced-->Network-->[[Network Settings]]'''
 
 
If you go to the "devices tree" in the [[LinuxMCE Admin Website]] you can see that the top level devices have MAC- and IP- addresses specified
 
If you go to the "devices tree" in the [[LinuxMCE Admin Website]] you can see that the top level devices have MAC- and IP- addresses specified
 
== LMCE loses its Network connection during the install ==
 
* Just go to a terminal and sudo ifdown eth0 and sudo ifup eth0 this should reconnect to internet.
 
** [http://forum.linuxmce.com/index.php?topic=1937.msg8820#msg8820 Forum Thread]
 
* To solve this just re-boot and re-start the LMCE installer when it loses connection, then it'll go all the way through.
 
** [http://forum.linuxmce.com/index.php?topic=1937.msg8854#msg8854 Forum Thread]
 
* Do '''sudo apt-get install arping''' before starting the LMCE installer, reboot first and make sure you are still connected to the net.
 
** [http://forum.linuxmce.com/index.php?topic=1937.msg8854#msg8854 Forum Thread]
 
 
== Applications are not started (Slimserver, Asterisk, ..) ==
 
Make sure you have a supported soundcard in the core. The AppServer device segfaults if amixer fails to detect the mixer. The fix involves adding a sound care or added a fake sound card as below:
 
modprobe snd-dummy
 
Make it permanent by adding snd-dummy to the end of /etc/modules by
 
vi /etc/modules
 
and adding snd-dummy to bottom of file.
 
 
 
== SPDIF output only gives sound with Dolby Digital (no PCM) ==
 
== SPDIF output only gives sound with Dolby Digital (no PCM) ==
 
Verify your mixer settings with e.g. "kmixer". Dolby Digital is not affected by the volume setting as it uses "ac3 passthrough".
 
Verify your mixer settings with e.g. "kmixer". Dolby Digital is not affected by the volume setting as it uses "ac3 passthrough".
 
 
== Generating Orbiter suddenly slows down at some point ==
 
== Generating Orbiter suddenly slows down at some point ==
 
Set fs.file-max=200000 in /etc/sysctl.conf and run sysctl -p
 
Set fs.file-max=200000 in /etc/sysctl.conf and run sysctl -p
 
 
== The settings in AVWizard are not good and X is crashing ==
 
== The settings in AVWizard are not good and X is crashing ==
Reboot the computer and press SHIFT when you hear the descending beeps.
+
Reboot the computer and hold SHIFT when you hear the descending beeps.
 
The AVWizard will start again.
 
The AVWizard will start again.
 
== MD unstable with prompt_user_window popping up ==
 
  
 
[[Category:Documentation]]
 
[[Category:Documentation]]

Latest revision as of 07:23, 14 June 2015

Reset the password for the LinuxMCE Admin site

Reset the password for the LinuxMCE Admin site

My device is not started properly

My device is not started properly

svn default properties

svn default properties

Adding new computing apps

Adding new computing apps

Installing on a new platform

Installing on a new platform

Windows|Installer for Windows

Installer for Windows

Installer Problems

Installer Problems

After installation my screen is black

After installation my screen is black

Testing and troubleshooting devices

Testing and troubleshooting devices

MDs Do Not Network (PXE) Boot

MDs Do Not Network (PXE) Boot

Internal and External networks swapped/not working

Internal and External networks swapped/not working

How to change LMCE's DHCP settings

Go to LinuxMCE Admin Website-->Advanced-->Network-->Network Settings If you go to the "devices tree" in the LinuxMCE Admin Website you can see that the top level devices have MAC- and IP- addresses specified

SPDIF output only gives sound with Dolby Digital (no PCM)

Verify your mixer settings with e.g. "kmixer". Dolby Digital is not affected by the volume setting as it uses "ac3 passthrough".

Generating Orbiter suddenly slows down at some point

Set fs.file-max=200000 in /etc/sysctl.conf and run sysctl -p

The settings in AVWizard are not good and X is crashing

Reboot the computer and hold SHIFT when you hear the descending beeps. The AVWizard will start again.