Difference between revisions of "Upgrading the Kernel"

From LinuxMCE
Jump to: navigation, search
Line 1: Line 1:
 
<table width="100%"> <tr><td bgcolor="#FFCFCF">This page was written by Pluto and imported with their permission when LinuxMCE branched off in February, 2007.  In general any information should apply to LinuxMCE.  However, this page should be edited to reflect changes to LinuxMCE and remove old references to Pluto.</td></tr> </table>[[Category:PlutoMaintenance]]
 
<table width="100%"> <tr><td bgcolor="#FFCFCF">This page was written by Pluto and imported with their permission when LinuxMCE branched off in February, 2007.  In general any information should apply to LinuxMCE.  However, this page should be edited to reflect changes to LinuxMCE and remove old references to Pluto.</td></tr> </table>[[Category:PlutoMaintenance]]
  
When upgrading the kernel for the pluto distribution, there are some things that we should take care of:
+
When upgrading the kernel for the LinuxMCE distribution, there are some things that we should take care of:
  
 
* Upgrade the alsa libraries and utilities to match the alsa kernel version
 
* Upgrade the alsa libraries and utilities to match the alsa kernel version

Revision as of 14:01, 15 March 2007

This page was written by Pluto and imported with their permission when LinuxMCE branched off in February, 2007. In general any information should apply to LinuxMCE. However, this page should be edited to reflect changes to LinuxMCE and remove old references to Pluto.

When upgrading the kernel for the LinuxMCE distribution, there are some things that we should take care of:

  • Upgrade the alsa libraries and utilities to match the alsa kernel version
  • Upgrade smbfs custom kernel modules (pluto-smbfs package)
  • Upgrade ftdi_sio module to work with zwave ( ftdi-sio-zvawe package )
  • Upgrade ivtv video drivers ( pluto-ivtv-video-drivers )
  • Upgrade cx88 video drivers ( pluto-cx88 )
  • Upgrade asterisk kernel modules
  • Upgrade lirc
make-kpkg --stem 'linux' --initrd --append-to-version="-pluto-1-686" --revision "2.6.16.20-1" --config oldconfig --us --uc configure buildpackage