User:Chrysemys

From LinuxMCE
Revision as of 06:51, 30 July 2010 by Chrysemys (Talk | contribs)

Jump to: navigation, search

Some 12 years of Debian experience might be enough to start useng LinuxMCE, just not much experience in editing wiki's

Started this project recently and assembled the following hardware:

Hardware

core

  • MoBo: MSI 770-C45
  • CPU: AMD Athlon(tm) II X4 620
  • RAM:(4GB) OCZ Platinum Low Voltage OCZ3P1333LV4GK
  • CPU cooler: Scythe Mugen 2 Rev. B
  • GPU: Club3D 9400GT HDMI Passive.
  • HD: 3x Samsung EcoGreen F2 EG HD154UI, 1.5TB
  • PSU: Nexus NX-5000 R3 530W; nice and silent if only the case fans could also perform that silent.
  • Case: Chieftec CA-01B-B-SL, a bit big, but lots of space for air circulation
  • TV-card: Hauppauge WinTV HVR-4000

Media Director

  • MoBo: MSI 770-C45
  • Case: Silverstone LC17
  • CPU: AMD Athlon(tm) II X2 215
  • CPU Cooler:Scythe Ninja Mini Rev. B
  • GPU: Club3D 9400GT HDMI Passive.
  • PSU: Nexus Value 430
  • Infrared Tranceiver: IguanaIR

Orbiters

  • Nokia N800
  • Nokia N810

Issues encountered

It is pretty modern hardware in comparison with Kubuntu-Intrepid, so I suspect some mods and tweaks are nessecary to get things running.

IguanaIR

First add the IguanaIR repository to /etc/apt/sources.list:

 deb-src http://iguanaworks.net/downloads/debian source/
 deb http://iguanaworks.net/downloads/debian binary-i386/
 deb http://iguanaworks.net/downloads/debian binary-amd64/

(Since MCE is 32-bits only, the last line is actually not necessary) Then go to a clean directory

(for example: sudo mkdir /usr/local/src/Lirc;cd /usr/local/src/Lirc) And issue

sudo apt-get update
sudo apt-get install iguanair
sudo apt-get build-dep lirc 
sudo apt-get -b source lirc

MoBo NIC

The on-board NIC (RTL 8111/8168B) is not supported by Intrepid's native desktop kernel. Considering to the age of Intrepid I decided to build a new 2.6.34.1 kernel according to http://www.howtoforge.com/kernel_compilation_ubuntu: How To Compile A Kernel - The Ubuntu Way.

installation MCE alpha-2

The installer started complaining it could not dld some packages which ik initially downloaded manually. At the third missing package I dived a bit deeper into it and added the line

  deb http://deb.linuxmce.org/ubuntu/ intrepid lmce-alpha2-updates

to /etc/apt/source.list which was enough.