Difference between revisions of "User:Jimbodude/Orbiter Phone"

From LinuxMCE
Jump to: navigation, search
Line 67: Line 67:
 
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6d71000)
 
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6d71000)
 
</pre>
 
</pre>
 +
*Attempting to install using deb packages
 +
**Created an apt repository with all LMCE packages on a USB flash drive
 +
**Not enough room on the tablet's flash to install all packages right now...

Revision as of 22:31, 3 December 2008

Plan

  1. Modify template 1759 to be "controlled by" template 8-Orbiter
  2. Add 1759 as a child device to an orbiter
  3. Find out if Orbiter starts simplephone, or if it must be started manually
  4. Look at the buttons on the telecom screens for "answer on this orbiter" - see how that works
    • Does this cause the phone to be answered on the MD? or the orbiter?

Progress

  • Template 1759 updated to be controlled by Orbiter (in addition to On-Screen Orbiter - which was already there)
  • Started SoftPhone install on WebDT
    • SimplePhone lives at /usr/pluto/bin/SimplePhone
    • ldd output is:
linuxmce@dcerouter:/usr/pluto/bin$ ldd SimplePhone 
	linux-gate.so.1 =>  (0xffffe000)
	libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7fcf000)
	librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7fc6000)
	libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7fc1000)
	libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7fbd000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7f00000)
	liblinphone.so.1 => /usr/lib/liblinphone.so.1 (0xb7ebf000)
	libSerializeClass.so => /usr/pluto/lib/libSerializeClass.so (0xb7ea4000)
	libDCECommon.so => /usr/pluto/lib/libDCECommon.so (0xb7dc1000)
	libPlutoUtils.so => /usr/pluto/lib/libPlutoUtils.so (0xb7d62000)
	libmysqlclient_r.so.15 => /usr/lib/libmysqlclient_r.so.15 (0xb7b77000)
	libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7b5f000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7a6c000)
	libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7a47000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7a3c000)
	libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb78f1000)
	/lib/ld-linux.so.2 (0xb7fe6000)
	libquickstream.so.0 => /usr/lib/libquickstream.so.0 (0xb78eb000)
	libosip2.so.3 => /usr/lib/libosip2.so.3 (0xb78d4000)
	libosipparser2.so.3 => /usr/lib/libosipparser2.so.3 (0xb78a9000)
	libnsl.so.1 => /lib/tls/i686/cmov/libnsl.so.1 (0xb7891000)
	libcrypt.so.1 => /lib/tls/i686/cmov/libcrypt.so.1 (0xb7862000)
	libz.so.1 => /usr/lib/libz.so.1 (0xb784d000)
	libmediastreamer.so.0 => /usr/lib/libmediastreamer.so.0 (0xb7828000)
	libavcodec.so.1d => /usr/lib/libavcodec.so.1d (0xb73cd000)
	libortp.so.5 => /usr/lib/libortp.so.5 (0xb73b6000)
	libasound.so.2 => /usr/lib/libasound.so.2 (0xb72ef000)
	libspeex.so.1 => /usr/lib/libspeex.so.1 (0xb72cf000)
	libtheora.so.0 => /usr/lib/libtheora.so.0 (0xb7296000)
	libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb719d000)
	libraw1394.so.8 => /usr/lib/libraw1394.so.8 (0xb7197000)
	libavutil.so.1d => /usr/lib/libavutil.so.1d (0xb718d000)
	libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb7164000)
	libogg.so.0 => /usr/lib/libogg.so.0 (0xb715f000)
	libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0xb70c8000)
	libgsm.so.1 => /usr/lib/libgsm.so.1 (0xb70b8000)
	libartsc.so.0 => /usr/lib/libartsc.so.0 (0xb70b2000)
	libesd.so.0 => /usr/lib/libesd.so.0 (0xb70a7000)
	libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0xb7085000)
	libaudio.so.2 => /usr/lib/libaudio.so.2 (0xb706f000)
	libXt.so.6 => /usr/lib/libXt.so.6 (0xb701e000)
	libdirectfb-0.9.so.25 => /usr/lib/libdirectfb-0.9.so.25 (0xb6fc7000)
	libfusion-0.9.so.25 => /usr/lib/libfusion-0.9.so.25 (0xb6fc1000)
	libdirect-0.9.so.25 => /usr/lib/libdirect-0.9.so.25 (0xb6fb1000)
	libaa.so.1 => /usr/lib/libaa.so.1 (0xb6f96000)
	libSM.so.6 => /usr/lib/libSM.so.6 (0xb6f8e000)
	libICE.so.6 => /usr/lib/libICE.so.6 (0xb6f76000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb6e85000)
	libncurses.so.5 => /lib/libncurses.so.5 (0xb6e40000)
	libslang.so.2 => /lib/libslang.so.2 (0xb6d7f000)
	libgpm.so.1 => /usr/lib/libgpm.so.1 (0xb6d79000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb6d76000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6d71000)
  • Attempting to install using deb packages
    • Created an apt repository with all LMCE packages on a USB flash drive
    • Not enough room on the tablet's flash to install all packages right now...