User:Phenigma

From LinuxMCE
Revision as of 23:22, 8 April 2010 by Phenigma (Talk | contribs)

Jump to: navigation, search

Operational System

  • Apr. 2010 - Running a DVD installed beta2 system.

Core - ASUS P4C800E-Deluxe - UI2

  • Intel P4 2.8Ghz, 2.5 GB RAM, 1GB LAN, Analog Audio
  • NVIDIA Geforce 6600 GT - VGA - 1280x1024
  • 120 GB SATA HDD
  • 100MB PCI NIC
  • CM11A - Removed
    • 19 Oct. 2009 - I've been fighting with a CM11A and two X10 appliance relays and I have come to the conclusion that X10 is old technology which should be taken out behind the shed and put down. It looks like noise on my power lines is causing the appliance relays to turn 'ON' whenever they feel like. LMCE is not the cause. I'll need to try ZWave or Insteon some time I've got disposable cash.

MD - Zotac IONITX-A-U Atom N330 1.6 Ghz - UI2

  • 2 GB RAM, 1GB LAN, Optical Digital Audio, VGA - 720P - VDPAU
  • USB-UIRT
  • Toshiba Plasma TV - 42HP86 - VGA
  • Yamaha AV Receiver - HTR-5760 - DD/DTS 5.1/PCM via S/PDIF

MD - ASUS EeeBox B202 Atom 230 1.6 Ghz - UI1

  • 1 GB RAM, 1GB LAN, Analog Audio, VGA - 800x600
  • Powered PC Speakers
  • Mediagate MCE Remote - I'm not sure what/if some of the buttons are supposed to do in LMCE yet... havn't been able to get the IR receiver to work yet. I'm using it with the USBUIRT anyways.

Orbiters

Networking

  • Linksys WRT350N - DD-WRT v24sp1
    • Internet Firewall
    • Asterisk 1.4 Server - SIP line (not yet controlled by LMCE)
  • Linksys PAP2T-NA ATA
  • 2 x D-Link 8-Port Gigabit Green switches

File Server

  • ASUS K8V-SE Deluxe
    • AMD Athlon 3000, 1GB RAM, 1GB LAN
  • PCI 100MB NIC
  • 3TB SATA HDDs - RAID5

Network Map

  • This map may seem rather complicated at first but is built this way out of necessity. I had a pre-existing network which serves my parents and my wife and I. The existing network had to remain stable throughout my learning curve with LMCE and could not be down for a 4 hour re-install, or more... As I am able, and stability permits, I will migrate devices to the LMCE network.
  • The Ubuntu NAS exists within both networks to serve files to PCs in the original network as well as the LMCE network, it's also my original Mythtv backend.
  • The laptops attach wirelessly to the LMCE network to run Windows Orbiter.

Xnetmap.jpg

Installation

Core

  • Disconnect all devices from the internal lmce network
  • Install according to the DVD installation instructions for 0810 beta2, LinuxMCE-0810_beta.
  • Edit the network settings in webadmin, remove .129 from valid address as this is set statically in my AP.
  • Update (create) /etc/apt/apt.conf.d/02proxy to point to my NAS/server running an updated build of apt-cacher-ng which is endlessly more stable than the version in Ubuntu 0810
echo 'Acquire::http { Proxy "http://ipaddress:3142"; };' | tee /etc/apt/apt.conf.d/02proxy
  • Install libdvdcss
apt-get update
apt-get install libdvdcss2 w32codecs
  • Create the initial MD images
/usr/pluto/bin/Diskless_CreateTBZ.sh
  • Turn devices on/plug-in one by one
  1. NAS/Server
  2. WebDT
  3. HDHomerun
  4. N800
  5. TabletPC1
  6. ZotacION
  7. EeeBox
  8. N900

MDs

  • Install libdvdcss & w32 codecs
apt-get update
apt-get install libdvdcss2 w32codecs

Outstanding Issues I need to investigate as I have time

  • MySQL optimizations/find out why my A/V datagrid queries take 6 seconds (or longer) to execute, add indexes (where applicable) and find out why UpdateMedia is constantly updating the database tables when my media isn't changing.
  • Proper (complete) device templates for TV, Receiver, PS3, Wii, 9242 PVR
  • UI2 on the EeeBox is elusive**Current driver causes segfault/cifs-vfs errors
    • Updated xorg and intel driver work great but mouse and keyboard events are not picked up by orbiter.
    • This has been pushed back to 1004 release, UI2 should work ootb with 1004 intel video drivers.
  • ZWave...
  • ...