User:Phenigma

From LinuxMCE
Revision as of 02:33, 22 February 2013 by Phenigma (Talk | contribs)

Jump to: navigation, search
dma.dmachans=0x3c bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708.boardrev=0x2 bcm2708.serial=0x29353735 smsc95xx.macaddr=B8:27:EB:35:37:35 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait

Operational System

  • Feb. 5, 2011- Running an 0810 DVD snapshot (23289) installed beta system with all current upgrades.
  • Jan. 1, 2012- Running a 1004 Internet install in dual-boot on same hardware
  • Feb. 18, 2012- Running a 1204 build of LMCE (home built) on kubuntu 1204 precise alpha 2.

Core/Hybrid

  • ASUS M4A87TD EVO w/AMD Athlon II X2 3.2Ghz - UI2
    • 4 GB RAM (32bit LMCE sees 3GB), Onboard Realtek 8111E 1GB LAN, S/PDIF Optical Audio
    • Palit nVidia GT210 512MB Fanless PCIe x16 2.0, DVI->HDMI - 1080P - VDPAU
    • Intel 1000CT PCIe NIC
    • USB-UIRT
    • Panasonic VIERA VT 50" 3D Plasma TV with Ethernet & RS-232 (RS-232 control)
    • Denon 3311CI HDMI AV Receiver with Ethernet & RS-232 (Ethernet control)
    • PS3 - Logitech Harmony Adapter - mimics PS3 blu-ray remote (IR control)
    • Bell 9242 Dual-Tuner PVR (IR control)
    • WD HD TV Live+ (IR control)
    • USB Bluetooth Adaptor - Wiimote, PS3 Sixaxis - not currently configured
    • Mediagate MCE Remote (via USBUIRT)
    • Rii Mini Wireless Keyboard/Mouse

MD #1

  • ASUS EeeBox B202 Atom 230 1.6 Ghz - UI1
    • 1 GB RAM, 1GB LAN, Analog Audio, VGA - 720P - xv
    • Powered PC Speakers
    • LCD Monitor

MD #2

  • Zotac IONITX-A-U Atom N330 1.6 Ghz - UI2
    • 2 GB RAM, 1GB LAN, Optical Digital Audio, VGA - 720P - VDPAU
    • Toshiba 42HP86 Plasma TV
    • PS3 - Logitech Harmony Adapter - mimics PS3 blu-ray remote (IR control)

Orbiters

  • WebDT 366LX (x4) - Modified PadOrbiter install with squeezeslaves
  • Nokia N800 - Diablo Orbiter
  • Nokia N900 - Fremantle Orbiter
  • 2x Samsung Galaxy S Glide (Captivate Glide in US) - QOrbiter/Android Web Orbiter
  • Samsung Galaxy Tab 10.1 4G - QOrbiter/Android Web Orbiter

Automation

Lighting

  • Z-Wave Light Switches x 4
  • Z-Wave Dimmer Switches x 2

Networking

  • Asus RT-N56U - Primary Firewall/Hardware NAT Translation Device
  • Linksys WRT350N - DD-WRT v24preSP2 - as Access Point
  • D-Link xxxx Router as Access Point
    • Internet Firewall
    • Asterisk 1.4 Server - SIP line (not yet controlled by LMCE)
  • Linksys PAP2T-NA ATA
  • Siemens Gigaset A600-IP - POTS & SIP Cordless Phone
  • 4 x D-Link 8-Port Gigabit Green switches

File Server

  • QNAP-410 TurboNAS
    • Marvell 800Mhz, 256MB RAM, 2x1GB LAN
    • 4x2TB SATA HDDs - RAID5
    • Debian running apt-cacher-ng.

Installation

Core

  • Disconnect the core from the internal lmce network
  • Internet Install (1004) or Boot the Installation DVD and choose "Install LinuxMCE" (0810), follow the instructions.
  • The onboard Realtek 8111e PCIe NIC needs updating from the manufacturer. Download, compile and install a new r8168.ko (0810)
  • Not Used -- The onboard VT1818 audio chip needs updated ALSA drivers, luckily these are included with LMCE already. (0810)
  • The Intel 1000CT PCIe NIC needs updating from the manufacturer. Download, compile and install a new e1000.ko (0810)
  • Continue Installing according to the DVD installation instructions for 0810 beta2, LinuxMCE-0810_beta.
  • Stop UpdateMedia from mangling my id3 tags, this causes updatemedia to import data but not update the file's id3tags.
echo SyncId3Files=false >> /etc/UpdateMedia.conf
  • (1004 is automagic now, thanks to L3mce) Install ALSA 1.0.20 (0810) or .24 (1004) drivers to enable HDMI on the Geforce GT210
sudo su
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.24.tar.bz2
tar xvf alsa-driver-1.0.24.tar.bz2
cd alsa-driver-1.0.24.tar.bz2
./configure
make all
make install
  • Unmute all 'S/PDIF X' outputs using alsamixer or by running:
amixer sset "IEC958,0" unmute
amixer sset "IEC958,1" unmute
amixer sset "IEC958,2" unmute
amixer sset "IEC958,3" unmute
  • Add the following to /etc/pluto/xine.conf to enable 5.1 PCM over hdmi (and therefor multichannel AAC). This works great in 0810, but the exact same setup in 1004 does not give multichannel AAC (through pcm on hdmi). The multichannel is being downmixed to stereo and sent pcm stereo over the hdmi in 1004.
audio.device.alsa_pcm_device:hdmi
audio.device.alsa_passthrough_device:hdmi
audio.device.alsa_surround40_device:hdmi
audio.device.alsa_surround51_device:hdmi
audio.output.speaker_arrangement:Pass Through
  • Install libdvdcss - This will be added to the default diskless MD image if installed on the core before running Diskless_CreateTBZ.
apt-get update
apt-get install libdvdcss2 w32codecs
  • Create the initial MD images
/usr/pluto/bin/Diskless_CreateTBZ.sh
  • Configure the D-Link DWA-552 as an Access Point
  • Turn devices on/plug-in one by one
  1. QNAP-NAS
  2. Zotac ION - and configure the onboard wireless as an Access Point
  3. EeeBox - UI1 only under 0810, UI2 under 1004
  4. WebDT
  5. N800
  6. TabletPC1
  7. N900
  8. HDHomerun

MDs

  • Install ms codecs
apt-get update
apt-get install w32codecs

TODO

  • Fix database data for ConfirmDependencies/MakeRelease
  • Create/Update package maintenance pages in webadmin
    • Add/Edit/List Operating Systems
    • Add/Edit/List Distributions
    • Add/Edit/List Repositories
    • Add/Edit/List Repository URLs
  • Build sources.list from database (with ConfirmDependencies?)
  • Move MD installation scripting/etc to a package so ConfirmDependencies/a package can install an MD.
  • Make webadmin usable on a builder

Useful Commands / Processes

Re-initialize the Media Database

(From forum post http://forum.linuxmce.org/index.php?topic=6408.msg70571#msg70571)

  • Disable the UpdateMedia daemon
# /usr/pluto/bin/UpdateMediaDaemonControl.sh –disable
  • Login to mysql and remove the database
# mysql -uroot
# drop database pluto_media;
# quit
  • Re-initialize the media database
# cp /usr/pluto/database/media.sqlcvs .
# /usr/pluto/bin/sqlCVS -D pluto_media -r media import
  • Re-start the UpdateMedia daemon
# /usr/pluto/bin/UpdateMediaDaemonControl.sh –enable

Set Root password on MD

Get superuser privs and enter your password:

$ sudo su -

chroot to the MDs environment (XX is the MD#), run passwd and enter your desired root password for this MD.

# chroot /usr/pluto/diskless/XX/
# passwd

You can now ssh, or login, to the MD as root.

The createbuilder.sh script

Posde shared a script in the forum to create a chroot LMCE0810 Builder from scratch.

http://forum.linuxmce.org/index.php?topic=3870.msg66857#msg66857

sqlCvS webadmin use

http://forum.linuxmce.org/index.php?topic=5758.msg33952#msg33952