Difference between revisions of "User talk:Bernz"

From LinuxMCE
Jump to: navigation, search
m
m (Annoyances (and Maybe Solutions))
 
Line 15: Line 15:
 
==== Annoyances (and Maybe Solutions) ====
 
==== Annoyances (and Maybe Solutions) ====
 
* '''Misaligned/badly sized text mode(s)''': The combination of TV and PC has resulted in the first (and maybe last) column of characters in text mode to be off-screen.  This isn't horrible, but annoying to be sure.
 
* '''Misaligned/badly sized text mode(s)''': The combination of TV and PC has resulted in the first (and maybe last) column of characters in text mode to be off-screen.  This isn't horrible, but annoying to be sure.
** There is an easy, sure-fire fix for this one: ''Menu'' (button on remote) -> ''Picture'' (option) -> ''Screen'' -> ''Position''.  Move the screen right (or wherever else necessary) to bring the hidden pixels into view.  It is possible to center the screen perfectly; I leave it to your imagination to figure out a way (there's more than one ;-).
+
** There is an easy, sure-fire fix for this one: ''Menu'' (button on remote) -> ''Picture'' (sub-menu) -> ''Screen'' -> ''Position''.  Move the screen right (or wherever else necessary) to bring the hidden pixels into view.  It is possible to center the screen perfectly; I leave it to your imagination to figure out a way (there's more than one ;-).
 
* '''Counter-intuitive OSD behaviour(s)''': The menu buttons on the remote feel good, and I often hit the desired one accidentally when guessing (still learning the feel of it).  The menu layouts are pretty awesome, too, but I've found one quirk when I adjust picture mode settings for User#.  Once I've reached a specific field, if I want to decrease the value (usually "arrow-left" on the remote), pressing left jumps back up the menu stack.  I would prefer this solution (other ideas are welcomed):
 
* '''Counter-intuitive OSD behaviour(s)''': The menu buttons on the remote feel good, and I often hit the desired one accidentally when guessing (still learning the feel of it).  The menu layouts are pretty awesome, too, but I've found one quirk when I adjust picture mode settings for User#.  Once I've reached a specific field, if I want to decrease the value (usually "arrow-left" on the remote), pressing left jumps back up the menu stack.  I would prefer this solution (other ideas are welcomed):
 
** (Suggested fix for manufacturer) Change the UI on the picture mode User1/User2 control panel (Contrast, Brightness, etc), so that "arrow-left" begins to adjust the selected item, just as "arrow-right" does.  In addition, change "Press [MENU] to confirm" to "Press [ENTER] to confirm or [MENU] to cancel" and change/add functionality to match the new text.  That would perfect the OSD UI!  :-)
 
** (Suggested fix for manufacturer) Change the UI on the picture mode User1/User2 control panel (Contrast, Brightness, etc), so that "arrow-left" begins to adjust the selected item, just as "arrow-right" does.  In addition, change "Press [MENU] to confirm" to "Press [ENTER] to confirm or [MENU] to cancel" and change/add functionality to match the new text.  That would perfect the OSD UI!  :-)

Latest revision as of 05:41, 17 July 2007

I discovered LinuxMCE via one of the newsaggs (I think it was reddit). I had been searching for a whole-home multimedia and automation setup, and this looks like one of the best bundles out there.

I'm slowly (and I stress that) building a multimedia extravaganza in my home. I intend to have everything automated as much as possible, mainly because it's possible -- I mean, we stopped living in caves, even though they were a reasonable form of shelter, right?

Anyway, I think it would be great to build a knowledge store about how well various hardware works with LinuxMCE. I call it the Suggested hardware page.

I am going to record my experiences installing Kubuntu Feisty (7.04) on an Epia CN100000EG Mini-ITX PC, with an LG 42LB5D LCD TV as the main display device, and a Harman/Kardon AVR245 receiver for audio. I'm starting to suspect the CN10000EG is a little underpowered for my purposes, although I don't intend to do anything much more CPU-intensive than playing DVDs, or digitized video or music. If you have a suggestion for a better motherboard that is fanless, please email me about it. Cheers!

Scratch pad:

  • I browsed through /var/log/Xorg.0.log, and discovered a few modelines that are compatible with the TV, including one that looks promising:
    Modeline "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1124 +hsync +vsync
    Okay, this modeline doesn't work perfectly; the image is off-center to the right, so I will have to keep playing with it. Unfortunately, xvidtune does not support my video hardware (the UniChrome).
  • I've tried my laptop with the TV, using the VGA-out. Windows XP Home is able to provide relatively good image quality at 1360x768, a resolution which the TV can match perfectly as a full 16:9 wide-screen format (you've GOTTA see full-screen media player visualizers like this!). I can also run at 1920x1080, but for my setup, there are two drawbacks:
    1. the amount of video swim, despite being fairly small, exceeds my personal tolerance
    2. the video hardware is a little too slow to watch full-screen video at full frame rate

Annoyances (and Maybe Solutions)

  • Misaligned/badly sized text mode(s): The combination of TV and PC has resulted in the first (and maybe last) column of characters in text mode to be off-screen. This isn't horrible, but annoying to be sure.
    • There is an easy, sure-fire fix for this one: Menu (button on remote) -> Picture (sub-menu) -> Screen -> Position. Move the screen right (or wherever else necessary) to bring the hidden pixels into view. It is possible to center the screen perfectly; I leave it to your imagination to figure out a way (there's more than one ;-).
  • Counter-intuitive OSD behaviour(s): The menu buttons on the remote feel good, and I often hit the desired one accidentally when guessing (still learning the feel of it). The menu layouts are pretty awesome, too, but I've found one quirk when I adjust picture mode settings for User#. Once I've reached a specific field, if I want to decrease the value (usually "arrow-left" on the remote), pressing left jumps back up the menu stack. I would prefer this solution (other ideas are welcomed):
    • (Suggested fix for manufacturer) Change the UI on the picture mode User1/User2 control panel (Contrast, Brightness, etc), so that "arrow-left" begins to adjust the selected item, just as "arrow-right" does. In addition, change "Press [MENU] to confirm" to "Press [ENTER] to confirm or [MENU] to cancel" and change/add functionality to match the new text. That would perfect the OSD UI!  :-)
  • Video swim: in higher-resolution modes, vertical lines may have a shimmer caused by the tiny sinusoidal horizontal oscillation of their component pixels, so the vertical edges of windows and other lines appear to have a slight shimmer/instability
    • I'm not sure there's a proper fix, but the effect can be reduced by using high quality, shielded cables, as short as possible, with no loops, and applying general electrical noise abatement techniques
    • Generally, swim increases as with resolution; often, even a slightly lower resolution can offer a great improvement in stability
    • Using a video card with better output options (DVI/HDMI) could be the best overall solution, but I have yet to try it