Talk:Display Drivers

From LinuxMCE
Jump to: navigation, search

Removed from the VIA section of the article page:

==== NOTE:--Usaf-lt-g 13:17, 2 August 2008 (PDT) ====

==== --Usaf-lt-g 14:01, 6 August 2008 (PDT)The steps mentioned BELOW were ONLY successful for UI1 not UI2. I have yet to get UI2 working, however these steps will work for 710 UI1. 

After following the below directions, you MAY experience your MD locking the next time it boots, if this the case... ssh to your core first and make sure you have root access by issuing the sudo -s command.

cd /tftpboot/pxelinux.cfg

locate the mac address of the MD and then
vi <your MAC address here>
place the acpi=off command at the end of the APPEND line.

save the file and reboot MD.

==== NOTE: --Usaf-lt-g 14:02, 6 August 2008 (PDT) You will most likely need to generate a new xorg.conf file as well. See the additional steps section on how to do this and how to set it up for your particular setup ==== NOTE:usaf-lt-g Sunday July 28th, 2008 ==== ---- Burgiman's instructions worked... with some minor modifications. Take note, I had a VERY difficult time first being able to SSH in to my MD. However, note, that I'm using an "earlier" version of LMCE (Beta 3). My MD is also diskless, and NETBIOS handled. If you can't gain root access to your MD through SSH I suggest the following method: ---- --Usaf-lt-g 22:55, 27 July 2008 (PDT) shell into your core as linuxmce / linuxmce and do the following:
---- sudo -s cd /usr/pluto/diskless chroot <your MD # found on the linuxmce admin devices page> (chroot will allow you to access the MD's file system as a root user) ---- from here I suggest you make a new group and user and then add them to the list of sudoers so that you can easily have SSH access to your MD anytime without this hassle. I did the following: ---- groupadd parents useradd -g parents chris passwd chris <set your password> visudo here you need to add a line below the: root ALL=(ALL) ALL </b> line. Mine was: chris ALL=(ALL) ALL
---- Now you'll be able to login using this user with password you supplied and issue the sudo -s command, which will grant you root access to the MD.
--Usaf-lt-g 22:55, 27 July 2008 (PDT) now from here you're going to need some additional packages installed before you can do anything with the OpenChrome drivers.
---- apt-get install subversion (which will give you the svn command) apt-get install xserver-xorg-dev
apt-get install libdrm-dev
apt-get install libxvmc-dev
---- After that, you SHOULD be able to follow the rest of the install below. It worked for me. Hope this helps.
Feel free to edit if necessary. Chris ====NOTE:ddamron Monday June 30, 2008==== Burgiman's instructions did NOT work for me. Take that for what it's worth. I had better success installing the VIA Unichrome Driver, and UI1. Use CLE266 mode. If you have more success, please update this page Dan UPDATED FOR 0710! --burgi 11:47, 2 June 2008 (PDT)
--burgi 13:37, 3 March 2008 (PST)