Difference between revisions of "Hardy-iglu"

From LinuxMCE
Jump to: navigation, search
(added fix for mysql startup script)
(UI1 related: removed UI1 playback issue, seems gone/can't reproduce)
Line 71: Line 71:
 
Confirmed by:  
 
Confirmed by:  
 
*Screen goes black after the screen saver.
 
*Screen goes black after the screen saver.
Confirmed by:  
+
Confirmed by:
*Media playback issue, the screen goes black after a bit.
+
Confirmed by: [[User:Zaerc|Zaerc]]
+
  
 
=====UI2 related=====
 
=====UI2 related=====

Revision as of 02:55, 10 September 2008

hardy-iglu is a test release build from the sources available in the LinuxMCE-0804 branch of SVN. It is missing several components of which the sources are not publicly available.

Versions available

The currently available version is alpha0, which is broken in numerous ways. This release was only intended to see if the installer works, and perhaps to provide a base for further development.

alpha0

The alpha0 release is broken pretty badly and definately not suited for actual use. This release is only available as a CD installer for the i386 platform, note that one of the ISO images is currently to big to fit on a CD.

Installation

It needs to be installed on a clean (not upgraded!) Kubuntu-8.04 desktop install (not 8.04.1!), and there are 2 packages (do not install or upgrade any others) that need to be installed before the lmce installer can be run sucessfully, like this:

apt-get update
apt-get install dpkg-dev msttcorefonts

Other then that, the instructions of the regular Installation Guide apply, except for the versions used.

In a nutshell:

  1. Install Kubutu-8.04 desktop from the live-CD.
  2. Install the dpkg-dev and msttcorefonts packages in advance as shown above.
  3. Copy the 3 ISOs (Iglu-0804_alpha0.i386.CD1.iso, Iglu-0804_alpha0.i386.CD2.iso and kubuntu-8.04-desktop-i386.iso) over to the fresh Kubuntu-8.04 desktop install.
  4. Mount Iglu-0804_alpha0.i386.CD1.iso, install the mce-installer_2.0.1-1_i386.deb package and unmount the ISO again.
  5. Run the installer by clicking the icon on the desktop, when it asks for the CDs simply point it at the corresponding ISO instead.
  6. Walk away and check back in an hour or so.

Post-install

After the install has finished edit the sources.list file to look something like this:

deb file:/usr/pluto/deb-cache/ ./

deb http://nl.archive.ubuntu.com/ubuntu/ hardy  main restricted multiverse universe
deb http://nl.archive.ubuntu.com/ubuntu/ hardy-security  main restricted multiverse universe
deb http://nl.archive.ubuntu.com/ubuntu/ hardy-updates  main restricted multiverse universe

deb http://packages.medibuntu.org/ hardy free non-free
deb http://debian.slimdevices.com/ stable main

Note that you may have a different ubuntu mirror then nl.archive.ubuntu.com that is probably more suitable, depending on what you chose during the installation of Kubuntu-8.04 of course. After modifying the sources.list file run the following commands:

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | apt-key add -
apt-get update

The installer also breaks the /etc/init.d/mysql script, it now fails to stop the database without generating an error. This can be corrected by commenting out the line containing "linuxmce", here's an easy way to do just that:

sed '/linuxmce/s/^.*$/#&/' -i /etc/init.d/mysql

Known problems

Please add all the issues you can find below, and/or add your name to the list of people confirming (simply sign it with ~~~).

General issues
  • Several buttons appear to be missing in the setup wizard, probaly just one or more missing graphics.

Confirmed by: Zaerc

  • The "Add Software" list is empty, this probably needs to be filled somewhere, see also "workarounds" below.

Confirmed by: Zaerc

  • There are entries for old repositories in the sources.list, they probably need to be removed

Confirmed by: Zaerc

  • Asterisk fails to run without giving an error.

Confirmed by: Zaerc

  • Sending the MobileOrbiter software to the phone fails as the binaries weren't build, however it does work if the orbiter was already installed on the phone by a previous version of lmce.

Confirmed by: Zaerc

UI1 related
  • Several graphics for buttons are missing from the video file list screen.

Confirmed by:

  • The back button is not working on the video file list screen.

Confirmed by:

  • Unable to click "Yes, do it now" or "No, do it later" on the "You have recently added or removed devices" screen.

Confirmed by:

  • Screen goes black after the screen saver.

Confirmed by:

UI2 related
  • Playback issue where the video is only visible when the UI is on-screen

Confirmed by: Zaerc

Workarounds and fixes

  • Installing libdvdcss and/or w32codecs.
apt-get update
apt-get install libdvdcss2 #if you want libdvdcss
apt-get install w32codecs #if you want the w32codecs

Confirmed by:

  • The External Media Identifier fails to start, this is because it wasn't build as the sources are not available.

Turn it off by disabeling it in the web-admin's "devices tree".

Confirmed by: Zaerc

The External Media Identifier can be installed successfully using the 07010 package. loacted at: /mnt/recovery/archives/deb-cache/id-my-disc_1.8.ub0710_i386.deb


Working.

Confirmed by: tkmedia

Confirmed Working

  • The mce-installer.

Confirmed by: Zaerc

  • The flickr photo screen saver.

Confirmed by: Zaerc

  • Diskless media director (with initial manual setup).

Confirmed by:

  • The Mobile-Orbiter, provided that the software was already installed on the device by a previous version of lmce.

Confirmed by: Zaerc