How to setup ADSL access?

From LinuxMCE
Revision as of 19:05, 20 April 2010 by Chris Caven (Talk | contribs)

Jump to: navigation, search


Setting up ADSL connection is not yet fully supported under LinuxMCE. But there is a relatively simple procedure to get it up and running. I'm posting my notes (hopefully didn't forget anything important)...

PPPoE

  1. setup two network cards as normally
  2. run pppconfig (follow instructions on screen)
  3. go into database - this is the SQL query for the database to see the current setting:
select * from Device_DeviceData where FK_Device=1 and FK_DeviceData=32; 

the data will look something like this:

eth1,10.0.0.85,255.255.255.0,10.0.0.1,10.0.0.150|eth0,192.168.80.1,255.255.255.0

you'll have to change the proper ethX in that string (eth1 in my case) with ppp0


4. put /etc/init.d/start_pppoe.sh and link it to /etc/rc2.d/S10start_pppoe


Content of start_pppoe.sh :


#!/bin/bash
export PATH="/usr/pluto/bin:$PATH"
. /usr/pluto/bin/pluto.func
if  -e /usr/pluto/install/.notdone ; then exit 1
fi
Logging "server" "1" "$0" "Running 'start_pppoe.sh'  ( \"/etc/init.d/start_pppoe.sh\" )"
ifconfig eth1 up
pon dsl-provider


4.a Alternative: Instead of doing 4 you can do following:

You could also simply append two lines

/sbin/ifconfig eth0 up
/usr/bin/pon dsl-provider

at the end of /etc/init.d/networking before "exit(0)", but I guess this will be overwritten by LinuxMCE. For me it works.

I hope that this will soon be easier to setup over web-admin page.