Difference between revisions of "Known Issues 0710 Beta4"

From LinuxMCE
Jump to: navigation, search
(added info about the DVD playback failure on the M/Ds and link to forums post with fix)
(formatting)
Line 1: Line 1:
 
* "Failed to get IVTV video driver" message on status window on Orbiter. This is because IVTV package fails to install.This can probably be safely ignored as the IVTV driver is now built into the Linux kernel.
 
* "Failed to get IVTV video driver" message on status window on Orbiter. This is because IVTV package fails to install.This can probably be safely ignored as the IVTV driver is now built into the Linux kernel.
 +
  
 
* VIA video support is a bit lame at the moment: Cursor leaves dandruff with OpenChrome drivers (fix is to enable SWCursor in xorg.conf, need to make default), MythTV menu text not always drawn with VIA proprietary drivers
 
* VIA video support is a bit lame at the moment: Cursor leaves dandruff with OpenChrome drivers (fix is to enable SWCursor in xorg.conf, need to make default), MythTV menu text not always drawn with VIA proprietary drivers
 +
  
 
* nVidia 7150 + and some 6150 and 7050 systems have high cpu problem. This causes high Xorg usage with MythTV + Xine, unless V-Sync disabled. On machines with SSE (most modern CPUs), the solution is to install nvidia drivers 169.12 and add
 
* nVidia 7150 + and some 6150 and 7050 systems have high cpu problem. This causes high Xorg usage with MythTV + Xine, unless V-Sync disabled. On machines with SSE (most modern CPUs), the solution is to install nvidia drivers 169.12 and add
 
  Option "UseEvents" "true"  
 
  Option "UseEvents" "true"  
 
to the video device section of the /etc/xorg.conf file. Then you can fully enable v-sync in nvidia-settings without drowning the CPU.
 
to the video device section of the /etc/xorg.conf file. Then you can fully enable v-sync in nvidia-settings without drowning the CPU.
 +
  
 
* Zwave children have the device data's and room reseted after reload router. A fixed was committed (svn rev #19914) in General Info Plugin for this. To fix this on your machine, follow the steps:
 
* Zwave children have the device data's and room reseted after reload router. A fixed was committed (svn rev #19914) in General Info Plugin for this. To fix this on your machine, follow the steps:
Line 55: Line 58:
 
* Asterisk/FreePBX (automatic) configuration seems to be broken.  It fails to accept incoming calls, the following error is logged:
 
* Asterisk/FreePBX (automatic) configuration seems to be broken.  It fails to accept incoming calls, the following error is logged:
 
  [Mar  6 23:11:25] WARNING[19471] pbx.c: Channel 'SIP/0878700000-081dffa8' sent into invalid extension '102' in context 'custom-linuxmce', but no invalid handler
 
  [Mar  6 23:11:25] WARNING[19471] pbx.c: Channel 'SIP/0878700000-081dffa8' sent into invalid extension '102' in context 'custom-linuxmce', but no invalid handler
 +
  
 
* Support disked MD was dropped completely in 0710
 
* Support disked MD was dropped completely in 0710
  
* The DVDs fail to play on the M/D but play OK on the Core.  
+
 
 +
* DVDs fail to play on the M/D but play OK on the Core.  
 
This is caused by the bug in the mounting script which is fixed already in the SVN. See the instruction how to patch your M/Ds in this post: http://forum.linuxmce.org/index.php?topic=4585.msg27572#msg27572
 
This is caused by the bug in the mounting script which is fixed already in the SVN. See the instruction how to patch your M/Ds in this post: http://forum.linuxmce.org/index.php?topic=4585.msg27572#msg27572

Revision as of 07:14, 21 March 2008

  • "Failed to get IVTV video driver" message on status window on Orbiter. This is because IVTV package fails to install.This can probably be safely ignored as the IVTV driver is now built into the Linux kernel.


  • VIA video support is a bit lame at the moment: Cursor leaves dandruff with OpenChrome drivers (fix is to enable SWCursor in xorg.conf, need to make default), MythTV menu text not always drawn with VIA proprietary drivers


  • nVidia 7150 + and some 6150 and 7050 systems have high cpu problem. This causes high Xorg usage with MythTV + Xine, unless V-Sync disabled. On machines with SSE (most modern CPUs), the solution is to install nvidia drivers 169.12 and add
Option "UseEvents" "true" 

to the video device section of the /etc/xorg.conf file. Then you can fully enable v-sync in nvidia-settings without drowning the CPU.


  • Zwave children have the device data's and room reseted after reload router. A fixed was committed (svn rev #19914) in General Info Plugin for this. To fix this on your machine, follow the steps:

- cd /usr/pluto/bin

- mv General_Info_Plugin.so General_Info_Plugin.so.orig

- wget -c ftp://builder32.linuxmce.com/Download/GIP-beta4-fix/i386/General_Info_Plugin.so (for i386)

or

- wget -c ftp://builder32.linuxmce.com/Download/GIP-beta4-fix/x86_64/General_Info_Plugin.so (for amd64)

- reload router


  • Sorting by genre, performed etc. doesn't work correctly. A fixed was committed (svn rev #19953) in Media Plugin for this. Also, now you can rip audio cd and play it in track order (the track number attribute will be attach to audio files). To fix this on your machine, follow the steps:

- cd /usr/pluto/bin

- mv Media_Plugin.so Media_Plugin.so.orig

- wget -c ftp://builder32.linuxmce.com/Download/Media_Plugin-beta4-fix/i386/Media_Plugin.so (for i386)

or

- wget -c ftp://builder32.linuxmce.com/Download/Media_Plugin-beta4-fix/x86_64/Media_Plugin.so (for amd64)

- reload router


  • MythTV affects performance of system because of too verbose logging, sometimes even freezing. The fix was commited (svn rev #19965). To fix it on your machine, follow the steps

- cd /usr/pluto/bin

- mv MythTV_Player MythTV_Player.orig

- wget -c ftp://builder32.linuxmce.com/Download/MythTV_Player-beta4-fix/i386/MythTV_Player (for i386)

or

- wget -c ftp://builder32.linuxmce.com/Download/MythTV_Player-beta4-fix/x86_64/MythTV_Player (for amd64)

- chmod +x MythTV_Player

- reload router


  • Asterisk/FreePBX (automatic) configuration seems to be broken. It fails to accept incoming calls, the following error is logged:
[Mar  6 23:11:25] WARNING[19471] pbx.c: Channel 'SIP/0878700000-081dffa8' sent into invalid extension '102' in context 'custom-linuxmce', but no invalid handler


  • Support disked MD was dropped completely in 0710


  • DVDs fail to play on the M/D but play OK on the Core.

This is caused by the bug in the mounting script which is fixed already in the SVN. See the instruction how to patch your M/Ds in this post: http://forum.linuxmce.org/index.php?topic=4585.msg27572#msg27572