Difference between revisions of "Mini-DCE eibd"

From LinuxMCE
Jump to: navigation, search
 
Line 1: Line 1:
 
[[Category: EIB/KNX]]
 
[[Category: EIB/KNX]]
 
[[category: Automation]]
 
[[category: Automation]]
[[Category: 0810]]
+
 
 
= Install eibd =
 
= Install eibd =
  

Latest revision as of 00:20, 28 September 2015


Install eibd

I compiled eibd from source:

Prerequisites (from README BCU SDK)

The BCU SDK needs the following software to be installed:

  • A reasonably recent Linux system (e.g. Fedora Core 2 or Debian Sarge)
  • GCC and G++ in version 3.3 or higher
  • libxml2 (plus development files) 2.6.16 or higher
  • flex (Debian users must install flex-old, if it is present, instead of flex)
  • bison
  • GNU make
  • xsltproc (part of libxslt)
  • xmllint (part of libxml2 sources)
  • indent (if you want a readable source code for the PHP and Java clients)
  • A java compiler and a jar tool, if you want to build the Java library.

Compile Pthsem

wget http://sourceforge.net/projects/bcusdk/files/pthsem/pthsem_2.0.8.tar.gz
./configure  # (I add -D_FORTIFY_SOURCE=0 to the CFLAGS while compiling pthsem. There seems to be a problem with FORTIFY_SOURCE on some archtiectures.).
make
make install

Compile EIBD from BCU SDK

wget http://sourceforge.net/projects/bcusdk/files/bcusdk/bcusdk_0.0.5.tar.gz
./configure --without-pth-test --enable-onlyeibd --enable-eibnetiptunnel
make
make install

Now modify rc.local

/sbin/route add 224.0.23.12 dev eth0
/usr/bin/eibd -i -u --eibaddr=0.0.1 --daemon=/var/log/eibd.log ipt:your_gateway_ip

Compile EIB_eibd

I modify the Makefile in src:

DCEDEVS=ZWave EIB-eibd Tongdy_RS485 # EnOcean_TCM120