Difference between revisions of "QOrbiter Targets"

From LinuxMCE
Jump to: navigation, search
 
Line 22: Line 22:
 
  Package: lmce-qorbiter
 
  Package: lmce-qorbiter
 
  Details: built on fluffy for 1204 or 1404.
 
  Details: built on fluffy for 1204 or 1404.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-desktop
 
  
 
== Non-Window Managed ==
 
== Non-Window Managed ==
Line 33: Line 30:
 
  Package: lmce-qorbiter
 
  Package: lmce-qorbiter
 
  Details: built on ph's builder for wheezy.
 
  Details: built on ph's builder for wheezy.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-desktop
 
  
 
= Non-OnScreen Orbiters =
 
= Non-OnScreen Orbiters =
Line 48: Line 42:
 
  Package: lmce-qorbiter-android
 
  Package: lmce-qorbiter-android
 
  Details: built on fluffy for android qt5 for 1204/1404.
 
  Details: built on fluffy for android qt5 for 1204/1404.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-android
 
  
 
=== iOS ===
 
=== iOS ===
Line 58: Line 49:
 
  Package: (n/a) no .deb package available currently  
 
  Package: (n/a) no .deb package available currently  
 
  Details: built by golgo for ios qt5.
 
  Details: built by golgo for ios qt5.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-ios
 
  
 
== Desktops/Laptops ==
 
== Desktops/Laptops ==
Line 73: Line 61:
 
  Package: lmce-qorbiter
 
  Package: lmce-qorbiter
 
  Details: built on fluffy for 1204 or 1404.
 
  Details: built on fluffy for 1204 or 1404.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-desktop
 
  
 
=== MacOSX ===
 
=== MacOSX ===
Line 84: Line 69:
 
  Package: (n/a) no .deb package available currently  
 
  Package: (n/a) no .deb package available currently  
 
  Details: built by golgo for OS/X qt5.
 
  Details: built by golgo for OS/X qt5.
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-desktop ???
 
  
 
=== Windows x86 ===
 
=== Windows x86 ===
Line 98: Line 80:
 
  Package: (n/a) no .deb package available currently  
 
  Package: (n/a) no .deb package available currently  
 
  Details: built by (n/a) not currently built anywhere
 
  Details: built by (n/a) not currently built anywhere
 
==== Skin Packages ====
 
Package: lmce-qorbiter-skins-desktop
 
 
== Skin Pacakges ==
 
=== lmce-qorbiter-skins-desktop ===
 
Package: lmce-qorbiter-skins-desktop
 
Depends: lmce-qorbiter-skins-common
 
Files..: qOrbiter_src/qml/qt5-desktop/*
 
Destination: .../skins/qt5-desktop/*
 
 
=== lmce-qorbiter-skins-android ===
 
Package: lmce-qorbiter-skins-android
 
Depends: lmce-qorbiter-skins-common
 
Files..: qOrbiter_src/qml/android/*
 
Destination: .../skins/android/*
 
 
=== lmce-qorbiter-skins-ios ===
 
Package: lmce-qorbiter-skins-ios
 
Depends: lmce-qorbiter-skins-common
 
Files..: qOrbiter_src/qml/ios/*
 
Destination: .../skins/ios/*
 
 
=== lmce-qorbiter-skins-common ===
 
Package: lmce-qorbiter-skins-common
 
Files..: qOrbiter_src/qml/skins-common/*
 
Destination: .../skins/skins-common/*
 

Latest revision as of 21:47, 11 September 2015

This page is meant as a roadmap to existing and expected qOrbiter targets, including specific requirements of each.

Forward Roadmap of current and future qOrbiter targets:

OnScreen Orbiters

Window Managed

Linux

Linux is the main platform qOrbiter is developed on.

  • LinuxMCE 1204 - Qt lib version = 5.2.0
  • LinuxMCE 1404 - Qt lib version = 5.2.1

Setup Linux qMD

  1. on your core edit /etc/initramfs-tools-interactor/scripts/DeviceTemplate change the line "DT=" to "DT=2277"
  2. run /usr/pluto/bin/Diskless_BuildDefaultImage.sh
  3. make sure to re-do this with the original values to create normal MDs again.

Binary Packages

Package: lmce-qorbiter
Details: built on fluffy for 1204 or 1404.

Non-Window Managed

Linux EGLFS (rpi/armhf)

  • LinuxMCE RPi Wheezy - Qt lib version = 5.2.0

Binary Packages

Package: lmce-qorbiter
Details: built on ph's builder for wheezy.

Non-OnScreen Orbiters

Mobile Tablets/Phones

Android

Android is the main target for smaller skins.

  • Qt lib version = 4.8.2 (necessitas)
  • Qt lib version = 5.3.2 NDK

Binary Packages

Package: lmce-qorbiter-android
Details: built on fluffy for android qt5 for 1204/1404.

iOS

  • iOS support added as the Qt 5.3 release.

Binary Packages

Package: (n/a) no .deb package available currently 
Details: built by golgo for ios qt5.

Desktops/Laptops

Linux

Linux is the main platform qOrbiter is developed on.

  • LinuxMCE 1204 - Qt lib version = 5.2.0
  • LinuxMCE 1404 - Qt lib version = 5.2.1
  • LinuxMCE RPi Wheezy - Qt lib version = 5.2.0

Binary Packages

Package: lmce-qorbiter
Details: built on fluffy for 1204 or 1404.

MacOSX

  • Qt lib version = 4.8.x builds to real OSX .app bundle with icon. Does actually work (checked may 2013)
  • Qt lib version = 5 does not compile atm

Binary Packages

Package: (n/a) no .deb package available currently 
Details: built by golgo for OS/X qt5.

Windows x86

Windows x86 successfully builds with the MSVC compiler.

Unfortunately, there is a segfault that happens shortly after skin-loading takes place. The root cause of the segfault has not yet been determined.

Qt lib version = 4.8.x (latest 4.x should be usable)

= Binary Packages

Package: (n/a) no .deb package available currently 
Details: built by (n/a) not currently built anywhere