Difference between revisions of "User:Markab"

From LinuxMCE
Jump to: navigation, search
Line 174: Line 174:
 
2009-01-19 20:49:12.730 Preview: Grabbed preview '/var/lib/mythtv/recordings/5069_20090119204859.mpg' 720x576@64s
 
2009-01-19 20:49:12.730 Preview: Grabbed preview '/var/lib/mythtv/recordings/5069_20090119204859.mpg' 720x576@64s
 
</pre>
 
</pre>
Also some Channels locks like they don't have EPG data.
+
<BR>
 +
Also some Channels locks like they don't have EPG data.<BR>
 +
-- [[User:Markab|Markab]] 23:29, 20 January 2009 (CET)<BR>
 +
Ups Channels where not set to get EPG, now it's OK.
 +
Just have to buy a Frontend for testing on my TV.<BR>
  
 
<h1>Setup Production ( Planed ) </h1>
 
<h1>Setup Production ( Planed ) </h1>

Revision as of 22:29, 20 January 2009

History about my Digital Home

After I read a Artikel in the german c't 23/2002 ( [1] Sonderwege von Georg Schnurer ) a Success Story about a Digital Home Implementation, it was clear for me that someday I also want something like this.

I will write here about my experiences installing a LinuxMCE Server, I hope this time I will have success. I also want to share my Expirense to other users who maybe want to do the same.

Setup Development

The Development System should be a Playground to learn what can LinuxMCE and what not. I try to do a Hybrid Setup with a old PC. It's clear for me that it's not for production use, but before I invest more Money I d'like to have a complet LinuxMCE Solution up and running. At my Home I have a Internet Connection to my local Cableprovider with a Bride, my Firewall is a Pfsense with 3 Interfaces ( WAN,LAN,WLAN ). This Firewall is my Defaultrouter. At the LAN Side I have a central Server with all necessary services ( DHCP, DNS Forward, ftp, smb,nfs,ntp, ) on a old Proliant. Now i have connected the LinuxMCE dev. Server Orion with the external NIC to this LAN and the other NIC is then the LinuxMCE Standard Net ( with the IP Range 192.168.80/24 ) Target is to setup the LinuxMCE dev. Server with MythTV and all other Services. I want live TV, scheduling and DVD / Video ripping, etc.

Hybrid

  • Mainboard: Elitegroup K8M800-M2
  • CPU: AMD Sempron 2200
  • Memory: 512 MB DDR RAM
  • HDD: 80 GB
  • NIC: Dual GB Nic, NC304
  • TV-Card ( DVB-C ): Mystique CaBiX-C2, DVB-C, HDTV / Mystique View CI-Interface (f. 1 CAM) PCI und 3.5" Variante / Conax CAM (Rev. 1.2) - 4.00e by Smit ( from dvbshop )
  • TV-Card ( analog ): Hauppauge PVR-350


Hybrid Network Overview


                  Internet
                      |
                      | 
                Firewall (def GW) ------( WLAN;192.168.Y )
                      | 
               (LAN;192.168.X )
                      | 
       ---------------|------------------------------------------------------------------ 
            |                       |                                   |
       LAN Server                   |                    Clients ( PC,Laptops, etc )
 ( DHCP,DNS,nfs,smb,etc)            |
                         LinuxMCE dev Server Orion
                            ( DHCP,Mythtv, Asterisk,etc )  
                                    | 
                         (LinuxMCE Net;192.168.80.0 ) 
                                    | 
                                    | 
                        ( LinuxMCE Test equipment  ) 


Hybrid Install Logbook

-- Markab 22:01, 5 January 2009 (CET)

  • after check out the Forum I decide to go with a DVD Installation I download the i386 and the amd64 images from the torrent mirrors describe on the Wikipage Mirrors 710
  • With this DVD I was not able to do a Installation, stops every time right at the beginning. The question about the Harddisk overwrite does not come up.
  • Luck that I found the DVD that provide Hari to me, with this DVD the Installation I was able to start the 32bit Installation and finish it.
  • I try to follow this Installation Guide and found than the DVD Install Guide DVD Installation
  • During the Installation I add my Monitor over the S-Video Connector from the PVR-350 but nothing appear. Only the VGA works. In the AV Wizard it is not clar for me what sort of connection should i take and why my TV-out from the PVR-350 does not work.
  • I hear the sound and also did the House Setup Wizard, but I did not modify the Network as describe in the DVD Install Page ( found it to late )

Problems:

  • MythTV don't work, not clear for me howto setup my TV - Cards ( digital DVB-C and analog PVR-350 )
  • Connection to Internet don't work, so I also can't update my Installation or install the DVD restricted Drivers
  • remote connection from my lAN don't work, not clear what is wrong IP / routing ok
  • check Graphikcard to support min. UI2 medium, maybe new Card needed
  • Mediadirector needed to check LinuxMCE functonality

Hardware Overview

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 44
model name	: AMD Sempron(tm) Processor 2800+
stepping	: 2
cpu MHz		: 1599.909
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm ts ttp tm stc
bogomips	: 3203.50
clflush size	: 64
00:09.0 Multimedia video controller: Internext Compression Inc iTVC15 MPEG-2 Encoder (rev 01)
	Subsystem: Hauppauge computer works Inc. WinTV PVR-350
	Flags: bus master, medium devsel, latency 64, IRQ 17
	Memory at e4000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [44] Power Management version 2

00:0a.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
	Subsystem: KNC One Unknown device 0022
	Flags: bus master, medium devsel, latency 32, IRQ 20
	Memory at ea0c0000 (32-bit, non-prefetchable) [size=512]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
	Subsystem: Elitegroup Computer Systems Unknown device 1877
	Flags: medium devsel, IRQ 21
	I/O ports at e400 [size=256]
	Capabilities: [c0] Power Management version 2
01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 01) (prog-if 00 [VGA])
	Subsystem: Elitegroup Computer Systems Unknown device 1b45
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
	Memory at e0000000 (32-bit, prefetchable) [size=64M]
	Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
	[virtual] Expansion ROM at e9000000 [disabled] [size=64K]
	Capabilities: [60] Power Management version 2
	Capabilities: [70] AGP version 3.0

Summary Frist Day: It's always really frustrating if you don't get any success. But I don't want to give up and try it again. If someone can give me a hint I really appreciate that! Thx Mike
Next steps: Wiki pages to check:


-- Markab 12:40, 6 January 2009 (CET)
found new Wikipage Alx9r's Sample Setup
-- Markab 00:48, 8 January 2009 (CET)
Finished the DVD Installation Setup with the Networkpart, also deactivate the firewall. Does not lock like it would help. I get some initial DHCP IP, also routing locks OK, but I can't ping my server and also have no access to the internet. There is a program after the DHCP - Client that change something.
-- Markab 22:56, 18 January 2009 (CET)
Found also some strange problems with liveTV and records ( lost some frames and audio is bad --> http://www.mail-archive.com/linux-dvb@linuxtv.org/msg08237.html, http://www.youtube.com/watch?v=Wa3xOSdJc2w ) Maybe a performance Problem on my AMD Sempron Testbox, do a complet reinstallation on my Desktop ( Intel Q6600 with 4GB Memory ) but don't help.
-- Markab 21:12, 19 January 2009 (CET)
Ok got it! It was the Conax CI Modul. After check the Signal strength over my cable modem I go to my provider and he check the conax module in a TV. My Conax CI has some Problem with some TV Station that are modulate on some Channel ( not really clear for me, have to check that later ) This is a known Problem ! The only Conax CI that works for my Provider is the Techisat Technicrypt CX Module ( Art-Nr.: 941304-62 ~100 CHF ex. www.conrad.ch ) Also my DVB-C Card from Satelco does not work, also not with this new Conax CI Card. Only the Mystique CaBiX-C2 works now OK. Also HD does work but need hugh CPU load, some Channels crash immediately.
Some Strange Errors left --> DTVSM(0) Error: Wrong PMT; pmt->pn. No Idea what's that

2009-01-19 20:49:10.201 New DB connection, total: 1
2009-01-19 20:49:10.226 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:10.227 Closing DB connection named 'DBManager0'
2009-01-19 20:49:10.232 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:10.236 New DB connection, total: 2
2009-01-19 20:49:10.244 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:10.248 Current Schema Version: 1214
2009-01-19 20:49:10.353 DTVSM(0) Error: Wrong PMT; pmt->pn(4101) desired(4100)
2009-01-19 20:49:10.356 DTVSM(0) Error: Wrong PMT; pmt->pn(4106) desired(4100)
2009-01-19 20:49:10.357 DTVSM(0) Error: Wrong PMT; pmt->pn(5101) desired(4100)
2009-01-19 20:49:10.475 DTVSM(0) Error: Wrong PMT; pmt->pn(3535) desired(4100)
2009-01-19 20:49:10.475 DTVSM(0) Error: Wrong PMT; pmt->pn(4102) desired(4100)
2009-01-19 20:49:10.479 DTVSM(0) Error: Wrong PMT; pmt->pn(4178) desired(4100)
2009-01-19 20:49:10.587 DTVSM(0) Error: Wrong PMT; pmt->pn(4061) desired(4100)
2009-01-19 20:49:10.588 DTVSM(0) Error: Wrong PMT; pmt->pn(4103) desired(4100)
2009-01-19 20:49:10.593 DTVSM(0) Error: Wrong PMT; pmt->pn(5099) desired(4100)
2009-01-19 20:49:10.701 DTVSM(0) Error: Wrong PMT; pmt->pn(4105) desired(4100)
2009-01-19 20:49:10.702 DTVSM(0) Error: Wrong PMT; pmt->pn(5100) desired(4100)
2009-01-19 20:49:10.969 Finished recording Der Rauch der Träume: channel 5100
2009-01-19 20:49:11.987 Finished recording Der Rauch der Träume: channel 5100
2009-01-19 20:49:11.999 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 15 min
2009-01-19 20:49:12.058 Using runtime prefix = /usr
2009-01-19 20:49:12.060 Empty LocalHostName.
2009-01-19 20:49:12.061 Using localhost value of antares
2009-01-19 20:49:12.065 New DB connection, total: 1
2009-01-19 20:49:12.069 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:12.070 Closing DB connection named 'DBManager0'
2009-01-19 20:49:12.072 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:12.076 New DB connection, total: 2
2009-01-19 20:49:12.080 Connected to database 'mythconverg' at host: localhost
2009-01-19 20:49:12.084 Current Schema Version: 1214
2009-01-19 20:49:12.090 Preview Error: Previewer file '/var/lib/mythtv/recordings/5100_20090119204909.mpg' is not valid.
2009-01-19 20:49:12.093 Preview Error: Run() file not local: '/var/lib/mythtv/recordings/5100_20090119204909.mpg'
2009-01-19 20:49:12.104 Preview Error: Preview process not ok.
                        fileinfo(/var/lib/mythtv/recordings/5100_20090119204909.mpg.png) exists: 0 readable: 0 size: 0
2009-01-19 20:49:12.685 AFD: Opened codec 0x218c8b0, id(MPEG2VIDEO) type(Video)
2009-01-19 20:49:12.688 AFD: codec MP3 has 2 channels
2009-01-19 20:49:12.689 AFD: Opened codec 0x218cd90, id(MP3) type(Audio)
2009-01-19 20:49:12.730 Preview: Grabbed preview '/var/lib/mythtv/recordings/5069_20090119204859.mpg' 720x576@64s


Also some Channels locks like they don't have EPG data.
-- Markab 23:29, 20 January 2009 (CET)
Ups Channels where not set to get EPG, now it's OK. Just have to buy a Frontend for testing on my TV.

Setup Production ( Planed )

Because my File Server is near EOL ( it's a old ML530 with Pentium3 in ) I will probably buy a HP ProLiant ML115 Generation 5 (G5). But this new Server has no PCI Slots anymore. Because it should be the Core, I need min. 2 Slots for the DVB-C Cards. At ARP I found a Expansion Box, PCI-E to PCI, with 4 Slots, that should fit my needs.

Core

  • Mainboard:
  • CPU:
  • Memory:
  • HDD:
  • NIC:


Media Director


Orbiters


Mobile Orbiters


AV

Phone


Home Automation


Security