User:PlatypusPedersen

From LinuxMCE
Revision as of 18:05, 14 June 2012 by PlatypusPedersen (Talk | contribs) (updated snap version)

Jump to: navigation, search

About me

  • Born: 1989
  • From: Norway
  • Occupation: Factory worker.
  • Other info: Love technology, but still GNU/Linux-illiterate and don't know how to program, hoping to resolve that but my boring job takes up all my energy.

Since I can't code, the least I can do is test the code that the good folks working on this project provides. I'm currently L3mce's bitch.

  • Contact: Platypus or Platypus-Man on IRC, PlatypusPedersen on the forum.

LinuxMCE setup

I am testing snapshots, will get better hw for Core/Hybrid when I can afford it. For now, all the gear is in one room. so the Location info below will be location in that room.

Misc tidbits for the current/next snapshot testing

  • Currently installed snapshot: LMCE-1004-20120613165726078.iso

If there's some specific stuff I should test, feel free to write that down here. For example:

  • Test the Headless option again instead of installing a Hybrid. PlatypusPedersen 03:23, 8 June 2012 (CEST)
  • Core: Hybrid
  • ID41:
  • Laptop MD 2: moon33

Core / Hybrid - dcerouter

  • Location: Closet
  • System: ZOTAC ION ITX-G
    • GPU: On-board nVidia ION of some sorts
    • CPU: Intel Atom 330 @ 1.6 GHz, dual-core
    • RAM: 2 GB 800 MHz DDR2 SDRAM, 240-pin (2x 1 GB)
    • Ports: The usual; HDMI, DVI-D, audio, USB2, gigabit network etc.
    • PXE: Works
    • Extra NIC: Don't remember the details, think it might be the one I got from lmcecompatible.com, but I'll have to check.
    • Notes;
      • Audio through HDMI worked flawlessly when I tried to test a snapshow while using my TV instead of a old VGA-connected monitor.
      • Considering the age, small formfactor and low wattage, even re-generating orbiters ain't that bad if you remember rule #1 for LMCE, but I think I might change my mind when I get better hardware for the Core/Hybrid, and see the difference.

Desktop MD 1 - ZBOX ID41

  • Location: Test-bench
  • System: ZOTAC ZBOX ID41
    • GPU: On-board nVidia Next Generation ION, 512 MB DDR3 SDRAM
    • CPU: Intel Atom D525 @ 1.8 GHz, dual-core
    • RAM: 4 GB 1333 MHz DDR3 SDRAM, 204-pin (2 x 2 GB)
    • Ports: The usual; HDMI, DVI-D, audio, USB2, gigabit network etc. Also has 2 USB3 ports.
    • PXE: Works
    • Notes:
      • On-board network was disabled in the BIOS by default for my device for some reason beyond my comprehension. After enabling it, reboot and go into the BIOS again to see it as an alternative for the boot priority.
      • The great and powerful L3mce is trying to work out the kinks with HDMI audio on it.
      • He got audio to pipe through HDMI on the LMCE-1004-20120524173925987.iso snapshot, but there were some funkyness with overwriting the config.

Desktop MD 2 - old ION

  • Location: Will re-purpose for LMCE (it's initial purpose when I bought it) soon.
  • System: ASUS AT3N7A-I
    • GPU: On-board nVidia ION, GeForce 9300
    • CPU: old Intel Atom
    • RAM: 2 GB DDR2 SDRAM, 240-pin (2x 1 GB)
    • Ports: The usual; HDMI, VGA, audio, USB2, gigabit network etc.
    • PXE: Not tested yet.

Laptop MD 1 - Acer

  • Location: Test-bench
  • System: Acer Aspire 5741G
    • GPU: nVidia GeForce GT 320M
    • CPU: Intel Core i5 430M @ 2,26 GHz
    • RAM: 4 GB
    • Ports: USB2, HDMI, VGA, audio, gigabit network
    • PXE: Works

Laptop MD 2 - Asus

  • Location: Test-bench
  • System: Asus A53S
    • GPU: 1 - on-board.
    • GPU: 2 - nVidia GeForce GT540M
    • CPU: Intel Core i7-2730QM @ 2 GHz
    • RAM: 8 GB (2x 4 GB)
    • Ports: USB2, DMI, VGA, audio, gigabit network
    • PXE: Works
    • Notes:
      • L3mce is doing some excellent work for dual-GPU handling.

Orbiters

None currently setup (except DiNovo Mini with limited success).

Automation

I have not played with any of these yet. Currently I only have Z-wave automation hardware, all of it bought from lmcecompatible.com.

  • 1x Aeon Labs Z-Stick Z-wave USB Adapter-S2
  • 1x Aeon Labs Minimote
  • 2x HomePro 2-Wire Wall Dimmer, ZDW232 - 25-500 W.
  • 1x HomePro Appliance Module, ZRP200

Other hardware

  • 2x USB-UIRT
  • Misc USB IR, BT and WiFi, not tested yet.
  • Wireless routers to be used within the network when I roll it out.
  • 1x 8-port gigabit dumb Linksys switch.
  • Logitech QuckCam Pro, will test with LMCE though I probably should get a proper IP camera.
  • 1x Nokia N9.... lots of bugs with this phone, but I hope that will be resolved and I can eventually use it as an Orbiter.
  • Plenty of 22" monitors to test machines on.
  • PlayStation 3, won't be on the internal network but DLNA seemed okay for photos, except the annoying thing that thumbs also showed up. Have not tried other media, as I presume my current Hybrid isn't juicy enough to transcode on-the-fly.

Command snippets and useful files & locations

Aka, shit that might come in handy.

zsync dowonload for Snapshots

Incremental download for snapshots can save some precious time and bandwith if you already have an .iso. This is done by first renaming your old .iso so that the name matches the new one, and then use the zsync command to download the new .iso.zsync file. For example, if the old iso ends with 987.iso:

mv LMCE*987.iso LMCE-1004-20120602141526029.iso
zsync http://linuxmce.iptp.org/snapshots/LMCE-1004-20120602141526029.iso.zsync

Add a .folderlock when moving files

Sometimes UpdateMedia wants to crawl files and folders before they are completely transferred, borking things up in the process. If copying into /home/public/data/videos/ simply do:

mkdir /home/public/data/videos/.folderlock
move your files
rmdir /home/public/data/videos/.folderlock

I tend to just create a */data/incoming/ folder and create a .folderlock there, then move the files into their proper directory when it is transferred to the correct disk, instead of constantly creating and removing the locks.

Turn off monitor via commandline

Panic button when watching porn? Might be useful someday.

xset dpms force off -display :0

To do

This list will basically never be completely checked-out.

  • Create a Network topology map and add to the Wiki.
  • Create Floorplan screens.
  • Do some more testing.
  • Try and get dynamic DNS to resolve to dcerouter/lmce-admin instead of the modem-page.
  • Play a bit with dcerouter -> wireless AP -> (bridged to another) -> wireless AP -> MD.
  • Learn the system better.
  • Break the system in ways not thought possible, to try and get it idiot-proof.
  • Get more MDs up and running.
  • Get Orbiters up and running.
  • Get a faster Core / Hybrid.
  • Test the WebCam and try to create Security Scenarios.
  • Figure out how to allow e.g. port 22 while LMCE firewall is enabled.
  • Get Z-Wave stuff up and running. Need an electrician to do the wall-switches.
  • Properly tag my media.

Done / Fixed

  • Figure out why the IONs perform so badly for 1080p, tearing issues etc (UI2 with alpha blending, tearing when watching media).
    • Silly me only tried changing the acceleration setting, not at all noticing the Graphics Card drop-down, which should have been on the GeForce option, alongside with the vpdau acceleration, 1080p mkv works flawlessly on my Hybrid. Hybrid and ID41 seem to peak at 5% CPU for 1080p.


More to come as I remember / find / steal stuff.