Difference between revisions of "ZWave"

From LinuxMCE
Jump to: navigation, search
(Overview: More properly linked to the ZWave wiki category using the proper mediawiki markup, and linked from a bit better place.)
m (To clean-up the Hardware category, added the ZWave category to the Hardware category, therefore this article can be reached directly through the ZWave category)
Line 2: Line 2:
 
   | __TOC__
 
   | __TOC__
 
   |}
 
   |}
[[Category: Hardware| ]]
 
 
[[Category: RF Control]]
 
[[Category: RF Control]]
 
[[Category: ZWave]]
 
[[Category: ZWave]]

Revision as of 15:59, 20 November 2009

Z-Wave™ is a wireless RF-based communications technology designed for residential and light commercial control and status reading applications such as meter reading, lighting and appliance control, HVAC, access control, intruder and fire detection.

Overview

The support from LinuxMCE system is represented by an executable ZWave (it's placed in /usr/pluto/bin) which is the device implementation and a DeviceTemplate (1754) which is used to create LinuxMCE Devices for ZWave.

Look at the Z-Wave Wiki Category to see pages for different Z-Wave devices.

The source code is available in LinuxMCE's SVN repository: http://svn.linuxmce.org/svn/branches/LinuxMCE-0810/src/ZWave.

Implementation

Open version

The new open Z-Wave driver will be included in the upcoming 0810 release.

A 32bit binary of the new Z-Wave driver for 0710 can be found here: http://vt100.at/files/ZWave-0.0.2-0710-32bit.bz2 Just swap with the existing /usr/pluto/bin/ZWave and quick reload the router.

New Fiire driver

Fiire also provides a new Z-Wave driver, it is binary only: Fiire ZWave Patch

Old version

This is the version shipped with 0710. The source code for the old version is not available as it depends on proprietary files from Zensys.

Interfaces

Supported

UNSUPPORTED

those don't work

How to install and use ZWave

Automatic installation - Lighting Wizard

The Lighting Wizard allows you to easily integrate LinuxMCE into your Z-Wave network. It is started after you plug in the Z-Wave dongle. Just follow the onscreen instructions.

Manual Setup using SIS Mode with the Tricklestar Remote

SIS mode currently needs either the Seluxit ViaSens ZWave USB controller installed or the new Tricklestar USB Controller (see here for info on installing this controller ZWave Device Template Plug'n'Play). Please note that you cannot currently use the Lighting Wizard when configuring SIS mode. You will also need to update to a current version of the new Open ZWave binary.

  1. Firstly reset your ZWave USB controller so that you can start to add devices in SIS mode. Use Web Admin ->Wizard->Devices->Interfaces and find the device called 'ZWave' and click its 'Advanced' button. In the next screen click on 'Send command to device' and then select 'Reset' from the drop-down list, Tick 'Delivery Confirmation' and then click 'Send Message'. Now if you see 'Message received OK' your ZWave USB controller has been successfully reset.
  2. Next we need to include your Tricklestar remote into your ZWave network. Firstly we need to set the remote into Configuration Mode (see also the manual) this is done with the little switch on the bottom side next to the USB connector. Then do the following button presses on the Tricklestar remote which should be in close proximity to the ZWave USB interface - Press and hold the Remotes top most button down until you see a Green LED light up then release the button and press it briefly again. The Green LED should now be blinking slowly (if it isn't then repeat this step again). Now back in Web Admin use the 'Send Command to Device' screen again and select 'Download Configuration' from the drop-down. Now click 'Send Message' and watch the slowly flashing Green LED on the remote. If the LED stops flashing and glows continuously green for a few seconds then you have succeeded in including the Remote. However if you see a Red LED displayed continuously for a few secs something went wrong - in this case please repeat this whole step again. Assuming you got a Green LED at the end of this step you should (after waiting a couple of minutes for the inclusion prcess to finish) do a reload router before continuing. NOTE: If it does not work that way, try sending the 'Download Configuration' command first and then press and hold the Remotes top most button down until it goes green and the press the same button again shortly, that way around it worked better for me (was a tip from Hari).
  3. Next we can Include each of your ZWave devices into the ZWave network (before starting to include devices it is important that they are located and fixed in their final locations). Using the Tricklestar remote go to each ZWave device (again you should be in close proximity to each device as you Include them) and do the following;
    1. Press and hold the Remotes top most button down until you see a Green LED light up then release the button and press it briefly again. The Green LED should now be blinking slowly (if it isn't then repeat this step again).
    2. Now briefly press the Inclusion button on the device you are including. You should see the remotes Green LED stop flashing and glow continuously Green for a few seconds. If you did then you have succeeded in including the device. However if you see a Red LED displayed continuously for a few secs something went wrong - in this case please repeat this whole step again.
    3. Repeat the step above for each ZWave device would like to include in your ZWave network.
  4. After including your last ZWave device, go back to Web Admin, do a reload router (or maybe two if LinuxMCE tells you to) and select Wizards->Devices->Lights. You should now see all the devices you included have been auto-magically added to the 'Wizard: Lights' screen! This is power of SIS mode! Now you can change your device names in the 'Description' field, select which 'Room' they are actually in and use 'PK_FloorplanObjectType' drop-down to select the floor plan icon they will display when placed on the floor plan etc. When you have updated this info for each ZWave device click 'Update' at the bottom of the screen.
  5. If devices are not added automatically - meaning there is no popup on the Orbiters showing "added new device X" - then you can try this. If you have added logging you wil see in /var/log/pluto/*_ZWave.log" that lightswitches are detected by the USB controller because it shows up like this "Got basic report from node X, value: X". After addind the first device go to the USB Controller and do a 'Download Configuration' like above again - but this time without doing a 'reset' first. Then do a quick reload router once or twice and try adding the next device. Now it should work.

Of course at anytime when you want to add some new ZWave devices to your installation just do the inclusion steps above with the remote & the device your adding - you dont need to add all your devices in one go. Each time you include a new device just do a reload router and auto-magically it will be in your ZWave devices tree.

Note, you should never do the download config again after you have initially added the USB controller to the Tricklestar remote. To add a new node just put the Tricklestar into config mode with the switch and then add the new nodes with the "up till flash- up" procedure. Same for device removal. The Tricklestar will notify the USB controller about the change. This is automatically detected by LinuxMCE and you will see a popup on all orbiters with the new zwave node id.

Manual Excluding devices using SIS Mode with the Tricklestar Remote

Why do I have to do this ? (Quote from hari) Z-Wave is a mesh. The routing table is updated at inclusion/exclusion. When you move stuff around without following the procedure (except portable devices like remote controllers) you can get network problems.

  1. Put the Configuration Switch of the Trickestar Remote in “Configuration Mode” like this. Press-and-hold “Up” Operation button for 2 seconds to enter Configuration Mode. LED Indicator will illuminate Green. Short-press the “Down” Operation Button one time to put the device into Exclusion Mode. The Green LED should now be blinking slowly (if it isn't then repeat this step again).
  2. Press the Exclusion Initiator of the Device to be Excluded (normally the same button as the Inclusion Initiator).
  3. LED Indicator on the Remote will illuminate Green when device is successfully excluded and illuminate Red if the operation is unsuccessful. Orbiters will show a message that the device is removed.
  4. Repeat steps 2-4 for each Device to be Excluded from the Network.
  5. After Excluding all the devices that you would like to remove, go back to Web Admin, do a reload router and select Wizards->Devices->Lights. The Excluded devices should now be gone.

Manual setup / Download configuration

Once you have successfully installed the ZWave USB controller and it is seen on LinuxMCE (media:zwave_homepro_interface.png), you can proceed by populating the ZWave network information to LinuxMCE.

  1. Add your ZWave devices to your master ZWave master remote controller (like ZTH200)
    • Once the devices are added to remote and verified they are working (you can control them with your remote controller), you need to copy the ZWave network information to LinuxMCE.
  2. Go to LinuxMCE admin page ("http://192.168.80.1/pluto-admin/"), then choose "Wizard -> Devices -> Interfaces -> [your ZWave controller] -> Advanced".
    1. On the device page select "Send command to device".
    2. Select command "Download Configuration" and choose "Send Message".
      • Leave the data and file fields as blank
  3. Now LinuxMCE is waiting for the ZWave information and you should send a copy of the ZWave network with your master remote controller to LinuxMCE.
    • If you are using HomePro remote controller this is done by selecting: "Setup -> Copy Remote Ctrl. -> Send Information -> Identical Copy". Once you have done that, the remote will show "Sending information..." and after successful sending it will return to clock screen (this shouldn't take more than couple of minutes).
    • You can monitor the process by watching the Zwave log file on LinuxMCE (usually "/var/log/pluto/*ZWave.log"). Unfortunately the admin page doesn't give much information of what is being done and is everything going smoothly. If the process is successfully, you should see the LinuxMCE communicating with the USB controller
    • Make sure the sending remote controller is near enough the USB receiver, otherwise nothing will happen.
  4. Go to device tree (Show devices tree) and you should see (Media:zwave_devices_tree.png) the newly added ZWave modules/devices on the tree under "CORE -> ZWave".

You should do quick reload (Wizard -> Restart -> Quick Reload Router) in order to use the newly added devices with LinuxMCE. Once you have done that you should be able to control (like switching on/off) the devices under the Light (Media:zwave_lights.png).

PIR (Binary Sensor) support

ACT Homepro Motion Detector

Z-Wave API documentation

ZWave API